summaryrefslogtreecommitdiffstats
path: root/recipes/subversion/subversion_1.4.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/subversion/subversion_1.4.5.bb')
-rw-r--r--recipes/subversion/subversion_1.4.5.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/subversion/subversion_1.4.5.bb b/recipes/subversion/subversion_1.4.5.bb
new file mode 100644
index 0000000000..d4f290590f
--- /dev/null
+++ b/recipes/subversion/subversion_1.4.5.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "The Subversion (svn) client"
+SECTION = "console/network"
+DEPENDS = "apr-util neon"
+RDEPENDS = "neon"
+LICENSE = "Apache BSD"
+HOMEPAGE = "http://subversion.tigris.org"
+
+PR = "r0"
+
+SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
+ file://disable-revision-install.patch;patch=1 \
+ file://neon-detection.patch;patch=1"
+
+EXTRA_OECONF = "--with-neon=${STAGING_EXECPREFIXDIR} \
+ --without-berkeley-db --without-apxs --without-apache \
+ --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
+ --with-apr-util=${STAGING_BINDIR_CROSS}"
+
+
+inherit autotools
+
+export LDFLAGS += " -L${STAGING_LIBDIR} "
+
+acpaths = "-I build/ -I build/ac-macros/"
+
+do_stage() {
+ autotools_stage_all
+}