aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sudo/files/noexec-link.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/sudo/files/noexec-link.patch')
-rw-r--r--recipes/sudo/files/noexec-link.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes/sudo/files/noexec-link.patch b/recipes/sudo/files/noexec-link.patch
new file mode 100644
index 0000000000..98b35c657b
--- /dev/null
+++ b/recipes/sudo/files/noexec-link.patch
@@ -0,0 +1,13 @@
+Index: sudo-1.6.8p6/Makefile.in
+===================================================================
+--- sudo-1.6.8p6.orig/Makefile.in 2005-01-21 19:09:26.963276656 -0500
++++ sudo-1.6.8p6/Makefile.in 2005-01-21 19:16:11.918714072 -0500
+@@ -187,7 +187,7 @@
+ $(CC) -o $@ $(TESTOBJS) $(LIBOBJS) $(LDFLAGS) $(LIBS) $(NET_LIBS)
+
+ sudo_noexec.la: sudo_noexec.lo
+- $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $@ sudo_noexec.lo -avoid-version -rpath $(noexecdir)
++ $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $@ sudo_noexec.lo -avoid-version -module -rpath $(noexecdir)
+
+ # Uncomment the following if you want "make distclean" to clean the parser
+ @DEV@PARSESRCS = sudo.tab.h sudo.tab.c lex.yy.c def_data.c def_data.h