aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sugar
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/sugar')
-rw-r--r--recipes/sugar/etoys/etoys.diff65
-rw-r--r--recipes/sugar/etoys_3.0.2076.bb25
-rw-r--r--recipes/sugar/files/acinclude.m490
-rw-r--r--recipes/sugar/sugar-artwork/icon-slicer.diff83
-rw-r--r--recipes/sugar/sugar-artwork_0.82.0.bb29
-rw-r--r--recipes/sugar/sugar-base_0.82.2.bb55
-rw-r--r--recipes/sugar/sugar-base_0.83.2.bb53
-rw-r--r--recipes/sugar/sugar-datastore_0.82.0.bb20
-rw-r--r--recipes/sugar/sugar-fructose.bb3
-rw-r--r--recipes/sugar/sugar-presence-service_0.82.2.bb31
-rw-r--r--recipes/sugar/sugar-sucrose.bb4
-rw-r--r--recipes/sugar/sugar-toolkit_0.82.11.bb22
-rw-r--r--recipes/sugar/sugar-toolkit_0.83.3.bb22
-rw-r--r--recipes/sugar/sugar_0.82.9.bb28
-rw-r--r--recipes/sugar/sugar_0.83.4.bb26
15 files changed, 556 insertions, 0 deletions
diff --git a/recipes/sugar/etoys/etoys.diff b/recipes/sugar/etoys/etoys.diff
new file mode 100644
index 0000000000..79b9acf51d
--- /dev/null
+++ b/recipes/sugar/etoys/etoys.diff
@@ -0,0 +1,65 @@
+--- /tmp/Makefile.in 2008-09-01 13:20:20.000000000 +0200
++++ etoys-3.0.2076/Makefile.in 2008-09-01 13:29:37.453198000 +0200
+@@ -79,23 +79,23 @@
+ dirs = $(bindir) $(etoysdir) $(mimedir) $(exmpldir) $(guidedir) $(docsdir)
+
+ install-etoys: Content
+- for d in $(dirs) ; do mkdir -p $$d ; done
+- install -v etoys $(bindir)
+- for f in $(etoys) ; do install -v -m 644 $$f $(etoysdir); done
+- for f in $(examples); do install -v -m 644 $$f $(exmpldir); done
++ for d in $(dirs) ; do mkdir -p $(DESTDIR)$$d ; done
++ install -v etoys $(DESTDIR)$(bindir)
++ for f in $(etoys) ; do install -v -m 644 $$f $(DESTDIR)$(etoysdir); done
++ for f in $(examples); do install -v -m 644 $$f $(DESTDIR)$(exmpldir); done
+ for f in $(guides); do \
+ dest=$(guidedir)/`basename $$f`; \
+ echo -n $$dest; \
+- ( gunzip -c $$f | gzip -v --rsyncable > $$dest ); \
+- chmod 644 $$dest; \
++ ( gunzip -c $$f | gzip -v --rsyncable > $(DESTDIR)$$dest ); \
++ chmod 644 $(DESTDIR)$$dest; \
+ done
+- for f in $(docs) ; do install -v -m 644 $$f $(docsdir); done
++ for f in $(docs) ; do install -v -m 644 $$f $(DESTDIR)$(docsdir); done
+ for f in $(mos) ; do \
+ dir=`dirname $$f|sed 's/^Content.//'` ; \
+- mkdir -p $(etoysdir)/$$dir ; \
+- install -v -m 644 $$f $(etoysdir)/$$dir ; \
++ mkdir -p $(DESTDIR)$(etoysdir)/$$dir ; \
++ install -v -m 644 $$f $(DESTDIR)$(etoysdir)/$$dir ; \
+ done
+- install -v -m 644 etoys.xml $(mimedir)
++ install -v -m 644 etoys.xml $(DESTDIR)$(mimedir)
+
+
+ # install activity - only used from sugar-jhbuild
+@@ -109,20 +109,20 @@
+ ./mkNews > $@
+
+ install-activity: $(activityall)
+- mkdir -p $(activitydir)/activity
+- mkdir -p $(activitydir)/bin
+- install -v etoys-activity $(activitydir)/bin
+- rm -f $(activitydir)/etoys-activity
+- install -v -m 644 NEWS $(activitydir)
+- install -v -m 644 activity.info $(activitydir)/activity
+- install -v -m 644 activity-etoys.svg $(activitydir)/activity
++ mkdir -p $(DESTDIR)$(activitydir)/activity
++ mkdir -p $(DESTDIR)$(activitydir)/bin
++ install -v etoys-activity $(DESTDIR)$(activitydir)/bin
++ rm -f $(DESTDIR)$(activitydir)/etoys-activity
++ install -v -m 644 NEWS $(DESTDIR)$(activitydir)
++ install -v -m 644 activity.info $(DESTDIR)$(activitydir)/activity
++ install -v -m 644 activity-etoys.svg $(DESTDIR)$(activitydir)/activity
+
+
+ # install both, etoys and activity.
+ # RPM uses install-etoys only, and runs update-mime as post script
+
+ install: install-etoys install-activity
+- update-mime-database $(datadir)/mime
++ update-mime-database $(DESTDIR)$(datadir)/mime
+
+ # build .xo bundle - invoke "make xo" manually
+
diff --git a/recipes/sugar/etoys_3.0.2076.bb b/recipes/sugar/etoys_3.0.2076.bb
new file mode 100644
index 0000000000..b124c5036e
--- /dev/null
+++ b/recipes/sugar/etoys_3.0.2076.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Sugar etoys"
+LICENSE = "GPLv2"
+
+PR = "r1"
+
+DEPENDS = "sugar"
+RDEPENDS = "sugar shared-mime-info"
+
+SRC_URI = "http://dev.laptop.org/pub/sugar/sources/etoys/etoys-${PV}.tar.gz \
+ file://etoys.diff;patch=1"
+
+inherit autotools distutils-base
+
+do_configure_prepend() {
+ mkdir -p ${S}/m4
+}
+
+PACKAGES_ARCH = "all"
+FILES_${PN} += "${datadir}/${PN} \
+ ${datadir}/xsessions \
+ ${datadir}/dbus-1 \
+ ${datadir}/sugar/activities \
+ ${sysconfdir} "
+
+
diff --git a/recipes/sugar/files/acinclude.m4 b/recipes/sugar/files/acinclude.m4
new file mode 100644
index 0000000000..53518fb2eb
--- /dev/null
+++ b/recipes/sugar/files/acinclude.m4
@@ -0,0 +1,90 @@
+## this one is commonly used with AM_PATH_PYTHONDIR ...
+dnl AM_CHECK_PYMOD(MODNAME [,SYMBOL [,ACTION-IF-FOUND [,ACTION-IF-NOT-FOUND]]])
+dnl Check if a module containing a given symbol is visible to python.
+AC_DEFUN(AM_CHECK_PYMOD,
+[AC_REQUIRE([AM_PATH_PYTHON])
+py_mod_var=`echo $1['_']$2 | sed 'y%./+-%__p_%'`
+AC_MSG_CHECKING(for ifelse([$2],[],,[$2 in ])python module $1)
+AC_CACHE_VAL(py_cv_mod_$py_mod_var, [
+ifelse([$2],[], [prog="
+import sys
+try:
+ import $1
+except ImportError:
+ sys.exit(1)
+except:
+ sys.exit(0)
+sys.exit(0)"], [prog="
+import $1
+$1.$2"])
+if $PYTHON -c "$prog" 1>&AC_FD_CC 2>&AC_FD_CC
+ then
+ eval "py_cv_mod_$py_mod_var=yes"
+ else
+ eval "py_cv_mod_$py_mod_var=no"
+ fi
+])
+py_val=`eval "echo \`echo '$py_cv_mod_'$py_mod_var\`"`
+if test "x$py_val" != xno; then
+ AC_MSG_RESULT(yes)
+ ifelse([$3], [],, [$3
+])dnl
+else
+ AC_MSG_RESULT(no)
+ ifelse([$4], [],, [$4
+])dnl
+fi
+])
+
+dnl a macro to check for ability to create python extensions
+dnl AM_CHECK_PYTHON_HEADERS([ACTION-IF-POSSIBLE], [ACTION-IF-NOT-POSSIBLE])
+dnl function also defines PYTHON_INCLUDES
+AC_DEFUN([AM_CHECK_PYTHON_HEADERS],
+[AC_REQUIRE([AM_PATH_PYTHON])
+AC_MSG_CHECKING(for headers required to compile python extensions)
+dnl deduce PYTHON_INCLUDES
+AC_ARG_WITH(python-includes,
+ [ --with-python-includes=DIR path to Python includes], py_exec_prefix=$withval)
+if test x$py_exec_prefix != x; then
+PYTHON_INCLUDES="-I${py_exec_prefix}/include/python${PYTHON_VERSION}"
+else
+py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
+py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
+PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
+if test "$py_prefix" != "$py_exec_prefix"; then
+ PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
+fi
+fi
+AC_SUBST(PYTHON_INCLUDES)
+dnl check if the headers exist:
+save_CPPFLAGS="$CPPFLAGS"
+CPPFLAGS="$CPPFLAGS $PYTHON_INCLUDES"
+AC_TRY_CPP([#include <Python.h>],dnl
+[AC_MSG_RESULT(found)
+$1],dnl
+[AC_MSG_RESULT(not found)
+$2])
+CPPFLAGS="$save_CPPFLAGS"
+])
+
+dnl
+dnl JH_ADD_CFLAG(FLAG)
+dnl checks whether the C compiler supports the given flag, and if so, adds
+dnl it to $CFLAGS. If the flag is already present in the list, then the
+dnl check is not performed.
+AC_DEFUN([JH_ADD_CFLAG],
+[
+case " $CFLAGS " in
+*@<:@\ \ @:>@$1@<:@\ \ @:>@*)
+ ;;
+*)
+ save_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS $1"
+ AC_MSG_CHECKING([whether [$]CC understands $1])
+ AC_TRY_COMPILE([], [], [jh_has_option=yes], [jh_has_option=no])
+ AC_MSG_RESULT($jh_has_option)
+ if test $jh_has_option = no; then
+ CFLAGS="$save_CFLAGS"
+ fi
+ ;;
+esac])
diff --git a/recipes/sugar/sugar-artwork/icon-slicer.diff b/recipes/sugar/sugar-artwork/icon-slicer.diff
new file mode 100644
index 0000000000..4eacb91251
--- /dev/null
+++ b/recipes/sugar/sugar-artwork/icon-slicer.diff
@@ -0,0 +1,83 @@
+From: Marco Pesenti Gritti <marco@localhost.localdomain>
+Date: Thu, 21 Aug 2008 12:52:39 +0000 (+0200)
+Subject: User icon-slicer to generate the icons, instead of cursorthemegen.
+X-Git-Url: http://dev.laptop.org/git?p=artwork;a=commitdiff_plain;h=2954f4c6d2c178ba005025a94f3d31e54fe37103
+
+User icon-slicer to generate the icons, instead of cursorthemegen.
+---
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -14,6 +14,8 @@ AC_PROG_CC
+ AC_HEADER_STDC
+ AC_PROG_LIBTOOL
+
++AC_PATH_PROG([ICON_SLICER], [icon-slicer])
++
+ PKG_CHECK_MODULES(GTK2, gtk+-2.0 >= 2.0.0,,
+ AC_MSG_ERROR([GTK+-2.0 is required to compile redhat-artwork]))
+
+@@ -46,7 +48,6 @@ fi
+ AC_OUTPUT([
+ Makefile
+ cursor/Makefile
+-cursor/cursorthemegen/Makefile
+ cursor/sugar/Makefile
+ icons/Makefile
+ icons/scalable/Makefile
+diff --git a/cursor/Makefile.am b/cursor/Makefile.am
+index 5f0148f..4fa44db 100644
+--- a/cursor/Makefile.am
++++ b/cursor/Makefile.am
+@@ -1 +1 @@
+-SUBDIRS = cursorthemegen sugar
++SUBDIRS = sugar
+
+diff --git a/cursor/sugar/Makefile.am b/cursor/sugar/Makefile.am
+index cb9beec..9af934c 100644
+--- a/cursor/sugar/Makefile.am
++++ b/cursor/sugar/Makefile.am
+@@ -1,6 +1,3 @@
+-THEMEGEN = $(top_builddir)/cursor/cursorthemegen/cursorthemegen
+-THEME_DIR = $(top_builddir)/cursor/sugar/theme
+-
+ all-local: sugar.stamp
+
+ sugar_images = \
+@@ -12,26 +9,24 @@ sugar_images = \
+ sugar-05.png \
+ sugar-06.png \
+ sugar-07.png \
+- sugar-08.png \
+- sugar-09.png \
+- sugar-10.png \
+- sugar-11.png \
++ sugar-08.png \
++ sugar-09.png \
++ sugar-10.png \
++ sugar-11.png \
+ sugar-hotspots.png
+
+ sugar.stamp: $(sugar_images) $(THEMEGEN) sugar.cursortheme
+- rm -rf sugar && \
+- BDIR=`pwd` && cd $(srcdir) && \
+- $$BDIR/$(THEMEGEN) sugar.cursortheme $$BDIR/theme && \
+- cd $$BDIR && touch sugar.stamp
++ $(ICON_SLICER) --image-dir=$(srcdir) --output-dir=$(builddir) $(srcdir)/sugar.cursortheme
++ touch sugar.stamp
+
+ clean-local:
+- rm -rf $(THEME_DIR)
+- rm -rf $(top_builddir)/cursor/sugar/sugar.stamp
++ rm -rf cursors
++ rm sugar.stamp
+
+ install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(datadir)/icons/sugar/cursors/
+- for i in `cd $(THEME_DIR) && echo *` ; do \
+- $(INSTALL) $(THEME_DIR)/$$i $(DESTDIR)$(datadir)/icons/sugar/cursors/$$i ; \
++ for i in `cd $(srcdir)/cursors && echo *` ; do \
++ $(INSTALL) $(srcdir)/cursors/$$i $(DESTDIR)$(datadir)/icons/sugar/cursors/$$i ; \
+ done
+
+ uninstall-local:
diff --git a/recipes/sugar/sugar-artwork_0.82.0.bb b/recipes/sugar/sugar-artwork_0.82.0.bb
new file mode 100644
index 0000000000..4a1ab847e5
--- /dev/null
+++ b/recipes/sugar/sugar-artwork_0.82.0.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Sugar artwork"
+LICENSE = "GPLv2"
+
+PR = "r1"
+
+DEPENDS = "sugar icon-slicer-native"
+
+SRC_URI = "http://dev.laptop.org/pub/sugar/sources/sugar-artwork/${PN}-${PV}.tar.bz2 \
+ file://icon-slicer.diff;patch=1"
+
+inherit autotools distutils-base
+
+do_configure_prepend() {
+ mkdir -p ${S}/m4
+}
+
+FILES_${PN} += "${datadir}/${PN} \
+ ${datadir}/icons \
+ ${datadir}/themes \
+ ${sysconfdir} "
+
+FILES_${PN}-dbg += "${libdir}/gtk-2.0/2.*/engines/.debug"
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/recipes/sugar/sugar-base_0.82.2.bb b/recipes/sugar/sugar-base_0.82.2.bb
new file mode 100644
index 0000000000..15c4e11f9d
--- /dev/null
+++ b/recipes/sugar/sugar-base_0.82.2.bb
@@ -0,0 +1,55 @@
+DESCRIPTION = "Sugar base system"
+LICENSE = "LGPLv2"
+
+PR = "r11"
+
+DEPENDS = "python-pygtk sugar-toolkit"
+RDEPENDS = "librsvg-gtk \
+ ohm-plugin-x11 ohm \
+ hippo-canvas \
+ python-datetime \
+ python-netclient \
+ python-pygtk \
+ sugar-toolkit \
+ python-logging \
+ python-dbus \
+ python-subprocess \
+ telepathy-gabble telepathy-salut telepathy-python \
+ sugar-presence-service \
+ python-crypt \
+ python-numpy \
+ python-compression \
+ python-gst \
+ python-simplejson \
+ python-misc \
+ python-xmlrpc \
+ python-compiler \
+ python-pydoc \
+ python-mmap \
+ python-doctest \
+ ssh-keygen"
+
+SRC_URI = "http://dev.laptop.org/pub/sugar/sources/sugar-base/${PN}-${PV}.tar.bz2"
+
+inherit autotools distutils-base
+
+SRC_URI += "file://acinclude.m4"
+
+EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
+}
+
+FILES_${PN} += "${datadir}/${PN} \
+ ${datadir}/dbus-1 \
+ ${sysconfdir} "
+
+FILES_${PN}-dbg += "${libdir}/python*/site-packages/sugar/.debug"
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/recipes/sugar/sugar-base_0.83.2.bb b/recipes/sugar/sugar-base_0.83.2.bb
new file mode 100644
index 0000000000..468ff3b0dc
--- /dev/null
+++ b/recipes/sugar/sugar-base_0.83.2.bb
@@ -0,0 +1,53 @@
+DESCRIPTION = "Sugar base system"
+LICENSE = "LGPLv2"
+
+DEPENDS = "python-pygtk sugar-toolkit"
+RDEPENDS = "librsvg-gtk \
+ ohm-plugin-x11 ohm \
+ hippo-canvas \
+ python-datetime \
+ python-netclient \
+ python-pygtk \
+ sugar-toolkit \
+ python-logging \
+ python-dbus \
+ python-subprocess \
+ telepathy-gabble telepathy-salut telepathy-python \
+ sugar-presence-service \
+ python-crypt \
+ python-numpy \
+ python-compression \
+ python-gst \
+ python-simplejson \
+ python-misc \
+ python-xmlrpc \
+ python-compiler \
+ python-pydoc \
+ python-mmap \
+ python-doctest \
+ ssh-keygen"
+
+SRC_URI = "http://download.sugarlabs.org/sources/sucrose/glucose/sugar-base/${PN}-${PV}.tar.bz2"
+
+inherit autotools distutils-base
+
+SRC_URI += "file://acinclude.m4"
+
+EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
+}
+
+FILES_${PN} += "${datadir}/${PN} \
+ ${datadir}/dbus-1 \
+ ${sysconfdir} "
+
+FILES_${PN}-dbg += "${libdir}/python*/site-packages/sugar/.debug"
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/recipes/sugar/sugar-datastore_0.82.0.bb b/recipes/sugar/sugar-datastore_0.82.0.bb
new file mode 100644
index 0000000000..918a8d01e8
--- /dev/null
+++ b/recipes/sugar/sugar-datastore_0.82.0.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Sugar datastore"
+LICENSE = "GPLv2"
+
+PR = "r0"
+
+DEPENDS = "sugar-toolkit python-xappy "
+RDEPENDS = "sugar-toolkit sugar-base python-xappy"
+
+SRC_URI = "http://dev.laptop.org/pub/sugar/sources/sugar-datastore/${PN}-${PV}.tar.bz2"
+
+inherit autotools distutils-base
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}
+
+
+FILES_${PN} += "${datadir}/dbus-1"
diff --git a/recipes/sugar/sugar-fructose.bb b/recipes/sugar/sugar-fructose.bb
new file mode 100644
index 0000000000..ad0db39ae9
--- /dev/null
+++ b/recipes/sugar/sugar-fructose.bb
@@ -0,0 +1,3 @@
+DESCRIPTION = "Sugar fructose activities"
+
+DEPENDS = "etoys sugar-web-activity"
diff --git a/recipes/sugar/sugar-presence-service_0.82.2.bb b/recipes/sugar/sugar-presence-service_0.82.2.bb
new file mode 100644
index 0000000000..0e9b171add
--- /dev/null
+++ b/recipes/sugar/sugar-presence-service_0.82.2.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Sugar presence service"
+LICENSE = "GPLv2"
+
+PR = "r1"
+
+DEPENDS = "sugar-toolkit"
+
+SRC_URI = "http://dev.laptop.org/pub/sugar/sources/${PN}/${PN}-${PV}.tar.bz2"
+
+inherit autotools distutils-base mime
+
+do_configure_prepend() {
+ mkdir -p ${S}/m4
+}
+
+FILES_${PN} += "${datadir}/${PN} \
+ ${datadir}/mime/packages \
+ ${datadir}/xsessions \
+ ${datadir}/dbus-1 \
+ ${sysconfdir} \
+ ${libdir}/python*/site-packages/"
+
+FILES_${PN}-dbg += "${libdir}/python*/site-packages/*/.debug"
+
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/recipes/sugar/sugar-sucrose.bb b/recipes/sugar/sugar-sucrose.bb
new file mode 100644
index 0000000000..3d176453e1
--- /dev/null
+++ b/recipes/sugar/sugar-sucrose.bb
@@ -0,0 +1,4 @@
+DESCRIPTION = "Complete sugar environment with core activities"
+
+#DEPENDS = "sugar sugar-fructose"
+DEPENDS = "sugar"
diff --git a/recipes/sugar/sugar-toolkit_0.82.11.bb b/recipes/sugar/sugar-toolkit_0.82.11.bb
new file mode 100644
index 0000000000..769706598e
--- /dev/null
+++ b/recipes/sugar/sugar-toolkit_0.82.11.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Sugar toolkit"
+LICENSE = "LGPLv2"
+DEPENDS = "python-pygtk libxml-parser-perl-native libxml2 gtk+ alsa-lib"
+
+SRC_URI = "http://dev.laptop.org/pub/sugar/sources/sugar-toolkit/sugar-toolkit-${PV}.tar.bz2"
+
+inherit autotools distutils-base
+
+SRC_URI += "file://acinclude.m4"
+
+EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
+}
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/recipes/sugar/sugar-toolkit_0.83.3.bb b/recipes/sugar/sugar-toolkit_0.83.3.bb
new file mode 100644
index 0000000000..864582d7e5
--- /dev/null
+++ b/recipes/sugar/sugar-toolkit_0.83.3.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Sugar toolkit"
+LICENSE = "LGPLv2"
+DEPENDS = "python-pygtk libxml-parser-perl-native libxml2 gtk+ alsa-lib"
+
+SRC_URI = "http://download.sugarlabs.org/sources/sucrose/glucose/sugar-toolkit/sugar-toolkit-${PV}.tar.bz2"
+
+inherit autotools distutils-base
+
+SRC_URI += "file://acinclude.m4"
+
+EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
+}
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/recipes/sugar/sugar_0.82.9.bb b/recipes/sugar/sugar_0.82.9.bb
new file mode 100644
index 0000000000..5f31e08c54
--- /dev/null
+++ b/recipes/sugar/sugar_0.82.9.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Sugar base system"
+LICENSE = "GPLv2"
+
+PR = "r4"
+
+DEPENDS = "sugar-toolkit libxml2 gtk+"
+RDEPENDS = "sugar-toolkit sugar-base sugar-datastore gnome-python-desktop"
+
+SRC_URI = "http://dev.laptop.org/pub/sugar/sources/sugar/${PN}-${PV}.tar.bz2"
+
+inherit autotools distutils-base mime
+
+do_configure_prepend() {
+ mkdir -p ${S}/m4
+}
+
+FILES_${PN} += "${datadir}/${PN} \
+ ${datadir}/mime/packages \
+ ${datadir}/xsessions \
+ ${datadir}/dbus-1 \
+ ${sysconfdir} "
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/recipes/sugar/sugar_0.83.4.bb b/recipes/sugar/sugar_0.83.4.bb
new file mode 100644
index 0000000000..955272df4d
--- /dev/null
+++ b/recipes/sugar/sugar_0.83.4.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Sugar base system"
+LICENSE = "GPLv2"
+
+DEPENDS = "sugar-toolkit libxml2 gtk+"
+RDEPENDS = "sugar-toolkit sugar-base sugar-datastore gnome-python-desktop"
+
+SRC_URI = "http://download.sugarlabs.org/sources/sucrose/glucose/sugar/${PN}-${PV}.tar.bz2"
+
+inherit autotools distutils-base mime
+
+do_configure_prepend() {
+ mkdir -p ${S}/m4
+}
+
+FILES_${PN} += "${datadir}/${PN} \
+ ${datadir}/mime/packages \
+ ${datadir}/xsessions \
+ ${datadir}/dbus-1 \
+ ${sysconfdir} "
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}
+