aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sugar
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/sugar')
-rw-r--r--recipes/sugar/sugar-base_0.84.1.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/recipes/sugar/sugar-base_0.84.1.bb b/recipes/sugar/sugar-base_0.84.1.bb
new file mode 100644
index 0000000000..e95a43e3a9
--- /dev/null
+++ b/recipes/sugar/sugar-base_0.84.1.bb
@@ -0,0 +1,53 @@
+DESCRIPTION = "Sugar base system"
+LICENSE = "LGPLv2"
+
+DEPENDS = "python-pygtk sugar-toolkit"
+RDEPENDS = "librsvg-gtk \
+ ohm-plugin-x11 ohm \
+ hippo-canvas \
+ python-datetime \
+ python-netclient \
+ python-pygtk \
+ sugar-toolkit \
+ python-logging \
+ python-dbus \
+ python-subprocess \
+ telepathy-gabble telepathy-salut telepathy-python \
+ sugar-presence-service \
+ python-crypt \
+ python-numpy \
+ python-compression \
+ python-gst \
+ python-simplejson \
+ python-misc \
+ python-xmlrpc \
+ python-compiler \
+ python-pydoc \
+ python-mmap \
+ python-doctest \
+ ssh-keygen"
+
+SRC_URI = "http://download.sugarlabs.org/sources/sucrose/glucose/sugar-base/${PN}-${PV}.tar.bz2"
+
+inherit autotools distutils-base
+
+SRC_URI += "file://acinclude.m4"
+
+EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
+}
+
+FILES_${PN} += "${datadir}/${PN} \
+ ${datadir}/dbus-1 \
+ ${sysconfdir} "
+
+FILES_${PN}-dbg += "${libdir}/python*/site-packages/sugar/.debug"
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}
+