aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/syslinux/syslinux_3.82.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/syslinux/syslinux_3.82.bb')
-rw-r--r--recipes/syslinux/syslinux_3.82.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes/syslinux/syslinux_3.82.bb b/recipes/syslinux/syslinux_3.82.bb
new file mode 100644
index 0000000000..4c4102e19d
--- /dev/null
+++ b/recipes/syslinux/syslinux_3.82.bb
@@ -0,0 +1,41 @@
+# syslinux OE build file
+# Copyright (C) 2009, O.S. Systems Software Ltda. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "A multi-purpose linux bootloader"
+HOMEPAGE = "http://syslinux.zytor.com/"
+LICENSE = "GPL"
+DEPENDS = "nasm-native"
+RRECOMMENDS_${PN} = "mtools"
+PR = "r0"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 "
+
+EXTRA_OEMAKE = " \
+ BINDIR=${bindir} SBINDIR=${base_sbindir} LIBDIR=${libdir} \
+ DATADIR=${datadir} MANDIR=${mandir} INCDIR=${includedir} \
+"
+
+do_configure() {
+ # drop win32 targets or build fails
+ sed -e 's,win32/\S*,,g' -i Makefile
+
+ # clean installer executables included in source tarball
+ oe_runmake clean
+}
+
+do_compile() {
+ # Rebuild only the installer; keep precompiled bootloaders
+ # as per author's request (doc/distrib.txt)
+ oe_runmake CC="${CC}" installer
+}
+
+do_install() {
+ oe_runmake install INSTALLROOT="${D}"
+}
+
+PACKAGES =+ "${PN}-extlinux ${PN}-mbr"
+FILES_${PN} = "${bindir}/syslinux"
+FILES_${PN}-extlinux = "${base_sbindir}/extlinux"
+FILES_${PN}-mbr = "${datadir}/${PN}/mbr.bin"
+FILES_${PN}-dev += "${datadir}/${PN}/com32"