aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sysvinit
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/sysvinit')
-rwxr-xr-xrecipes/sysvinit/sysvinit/angstrom/rc13
-rw-r--r--recipes/sysvinit/sysvinit_2.86.bb2
2 files changed, 8 insertions, 7 deletions
diff --git a/recipes/sysvinit/sysvinit/angstrom/rc b/recipes/sysvinit/sysvinit/angstrom/rc
index 30b69ad516..6c5f4ca2ec 100755
--- a/recipes/sysvinit/sysvinit/angstrom/rc
+++ b/recipes/sysvinit/sysvinit/angstrom/rc
@@ -16,6 +16,9 @@
#
. /etc/default/rcS
+if [ -f /etc/default/splashfuncs ]; then
+ . /etc/default/splashfuncs
+fi
export VERBOSE
startup_progress() {
@@ -26,9 +29,7 @@ startup_progress() {
progress=$progress_size
fi
#echo "PROGRESS is $progress $runlevel $first_step + ($step of $num_steps) $step_change $progress_size"
- if type psplash-write >/dev/null 2>&1; then
- TMPDIR=/mnt/.psplash psplash-write "PROGRESS $progress" || true
- fi
+ status_position $progress || true
}
@@ -169,8 +170,8 @@ startup() {
#Uncomment to cause psplash to exit manually, otherwise it exits when it sees a VC switch
#if [ "x$runlevel" != "xS" ]; then
-# if type psplash-write >/dev/null 2>&1; then
-# TMPDIR=/mnt/.psplash psplash-write "QUIT" || true
-# umount /mnt/.psplash
+# if type splash-write >/dev/null 2>&1; then
+# TMPDIR=/mnt/.splash splash-write "QUIT" || true
+# umount /mnt/.splash
# fi
#fi
diff --git a/recipes/sysvinit/sysvinit_2.86.bb b/recipes/sysvinit/sysvinit_2.86.bb
index 6e6f98c6ed..d3a151703f 100644
--- a/recipes/sysvinit/sysvinit_2.86.bb
+++ b/recipes/sysvinit/sysvinit_2.86.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "System-V like init."
SECTION = "base"
LICENSE = "GPL"
HOMEPAGE = "http://freshmeat.net/projects/sysvinit/"
-PR = "r46"
+PR = "r52"
# USE_VT and SERIAL_CONSOLE are generally defined by the MACHINE .conf.
# Set PACKAGE_ARCH appropriately.