aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/taglib/taglib_1.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/taglib/taglib_1.4.bb')
-rw-r--r--recipes/taglib/taglib_1.4.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/taglib/taglib_1.4.bb b/recipes/taglib/taglib_1.4.bb
new file mode 100644
index 0000000000..e50eeb6490
--- /dev/null
+++ b/recipes/taglib/taglib_1.4.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "TagLib is a library for reading and editing the meta-data of several popular audio formats"
+SECTION = "libs/multimedia"
+HOMEPAGE = "http://developer.kde.org/~wheeler/taglib.html"
+LICENSE = "LGPL"
+PR = "r2"
+
+SRC_URI = "http://developer.kde.org/~wheeler/files/src/taglib-${PV}.tar.gz \
+ file://taglib_1.4-8.diff.gz;patch=1"
+S = "${WORKDIR}/taglib-${PV}"
+
+inherit autotools pkgconfig binconfig
+
+do_postpatch() {
+ rm -rf patches && rm -rf .pc && mv -f debian/patches patches && quilt push -av
+}
+addtask postpatch after do_patch before do_configure
+
+do_stage() {
+ autotools_stage_all
+}
+
+PACKAGES =+ "${PN}-c"
+FILES_${PN}-dbg += "${bindir}/taglib-config"
+FILES_${PN}-c = "${libdir}/libtag_c.so.*"