aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tasks/task-proper-tools.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/tasks/task-proper-tools.bb')
-rw-r--r--recipes/tasks/task-proper-tools.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/tasks/task-proper-tools.bb b/recipes/tasks/task-proper-tools.bb
new file mode 100644
index 0000000000..c5045a13f5
--- /dev/null
+++ b/recipes/tasks/task-proper-tools.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Full versions of tools provided by busybox"
+PR = "r9"
+
+inherit task
+
+RDEPENDS_${PN} = "\
+ coreutils \
+ findutils \
+ util-linux-ng \
+ grep \
+ gawk \
+ sed \
+ wget \
+ patch \
+ tar \
+ diffutils \
+ less \
+ vim \
+ e2fsprogs \
+ binutils-symlinks \
+ module-init-tools \
+ net-tools \
+ iproute2 \
+ iputils \
+ psmisc \
+ debianutils \
+ tcptraceroute \
+ fbset \
+ "
+#
+# binutils-symlinks provide ar in a way which conflict with busybox - #1465 for more info
+#
+# busybox tar does not understand '--no-same-owner' option which bitbake use
+#