summaryrefslogtreecommitdiffstats
path: root/recipes/tasks
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/tasks')
-rw-r--r--recipes/tasks/task-gpephone.bb91
-rw-r--r--recipes/tasks/task-sdk-gpephone.bb21
-rw-r--r--recipes/tasks/task-shr-feed.bb4
-rw-r--r--recipes/tasks/task-shr-minimal.bb3
4 files changed, 5 insertions, 114 deletions
diff --git a/recipes/tasks/task-gpephone.bb b/recipes/tasks/task-gpephone.bb
deleted file mode 100644
index a77233bedc..0000000000
--- a/recipes/tasks/task-gpephone.bb
+++ /dev/null
@@ -1,91 +0,0 @@
-DESCRIPTION = "Task packages for GPE Palmtop Environment Phone Edition"
-PR = "r10"
-LICENSE = "MIT"
-
-inherit task
-
-PACKAGES = "\
- gpephone-task-base \
- gpephone-task-settings \
- gpephone-task-pim \
- gpephone-task-connectivity \
- gpephone-task-apps \
- gpephone-task-development"
-
-RDEPENDS_gpephone-task-development = "\
- rxvt-unicode \
- gpe-terminal \
- gpe-edit \
- gdb \
- strace \
- e2fsprogs \
- bluez-utils-compat \
- minicom"
-
-RDEPENDS_gpephone-task-base = "\
- cms92init \
- gsmmux \
- connect \
- phoneserver \
- soundserver \
- voicecall \
- vochistory \
- sms \
- audioplayer \
- videoplayer \
- addressbook \
- calendar \
- gpe-applauncher \
- gpe-phonepanel \
- gpe-bootsplash \
- gpe-bootsplash-theme-gpephone \
- bluez-utils-dbus \
- matchbox \
- xcursor-transparent-theme \
- gtk2-theme-angelistic \
- matchbox-themes-gtk \
- xst \
- xhost \
- xrdb \
- gpe-soundserver \
- ttf-bitstream-vera \
- ttf-dejavu-sans \
- ttf-dejavu-sans-mono \
- gpe-dm \
- gpe-login \
- gpe-session-scripts-phone \
- gpe-icons \
- gpe-confd \
- gpe-autostarter \
- xauth \
- gdk-pixbuf-loader-png \
- gdk-pixbuf-loader-xpm \
- gdk-pixbuf-loader-jpeg \
- gdk-pixbuf-loader-gif \
- pango-module-basic-x \
- pango-module-basic-fc \
- detect-stylus \
- ptim-manager \
- ptim-helper \
- ptim-engine \
- ${@base_contains("MACHINE_FEATURES", "touchscreen", "libgtkstylus xtscal", "",d)} \
-"
-
-RDEPENDS_gpephone-task-pim = "\
- gpesyncd"
-
-RDEPENDS_gpephone-task-settings = "\
- gpe-su \
- gpe-conf \
- gpe-mixer \
- gpe-taskmanager \
- minilite \
- machined"
-
-RDEPENDS_gpephone-task-apps = "\
- gpe-what \
- gpe-scap \
- gpe-windowlist"
-
-RDEPENDS_gpephone-task-connectivity = "\
-"
diff --git a/recipes/tasks/task-sdk-gpephone.bb b/recipes/tasks/task-sdk-gpephone.bb
deleted file mode 100644
index df5bca7d68..0000000000
--- a/recipes/tasks/task-sdk-gpephone.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-DESCRIPTION = "SDK task for GPE Phone Edition"
-PR = "r1"
-LICENSE = "MIT"
-ALLOW_EMPTY = "1"
-
-RDEPENDS_${PN} = "\
- libidn-dev \
- libim-dev \
- gloox-dev \
- libabenabler-dev \
- libcalenabler-dev \
- libchenabler-dev \
- libgemwidget-dev \
- libiac-dev \
- libim-dev \
- liblipsevent-dev \
- libmsgenabler-dev \
- librecord-dev \
- libvocenabler-dev \
- linphone-dev \
- "
diff --git a/recipes/tasks/task-shr-feed.bb b/recipes/tasks/task-shr-feed.bb
index b41b7c9755..96b5940511 100644
--- a/recipes/tasks/task-shr-feed.bb
+++ b/recipes/tasks/task-shr-feed.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "SHR Feed"
-PR = "r74"
+PR = "r76"
PV = "1.0"
LICENSE = "GPL"
@@ -113,6 +113,7 @@ RDEPENDS_${PN} += "\
libpurple-protocol-msn \
libpurple-protocol-icq \
vagalume \
+ udev \
ppp \
bluez-hcidump \
kbdd \
@@ -308,6 +309,7 @@ RDEPENDS_${PN} += "\
minneo \
gnuplot \
galculator \
+ xterm \
"
# this is only usefull on gta02 and on other devices it's trying to pull mesa-dri (not respecting DEFAULT_PROVIDER for virtual/libgl)
diff --git a/recipes/tasks/task-shr-minimal.bb b/recipes/tasks/task-shr-minimal.bb
index 4e7dbae0d5..7d933a08b1 100644
--- a/recipes/tasks/task-shr-minimal.bb
+++ b/recipes/tasks/task-shr-minimal.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "SHR Lite Image Feed"
-PR = "r33"
+PR = "r34"
PV = "2.0"
LICENSE = "GPL"
@@ -140,5 +140,6 @@ RDEPENDS_${PN}-gtk = "\
vala-terminal \
pyphonelog \
matchbox-keyboard-im \
+ gtk-immodule-xim \
"