summaryrefslogtreecommitdiffstats
path: root/recipes/tasks
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/tasks')
-rw-r--r--recipes/tasks/task-base.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes/tasks/task-base.bb b/recipes/tasks/task-base.bb
index ed561b802e..6aad8730e2 100644
--- a/recipes/tasks/task-base.bb
+++ b/recipes/tasks/task-base.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Merge machine and distro options to create a basic machine task/package"
-PR = "r86"
+PR = "r87"
inherit task
@@ -60,6 +60,9 @@ HOTPLUG ?= "${@base_contains("MACHINE_FEATURES", "kernel24", "linux-hotplug",""
#
DISTRO_SSH_DAEMON ?= "dropbear"
+# Distro can override apm provider
+DISTRO_apm ?= "apm"
+
#
# bluetooth manager
#
@@ -190,7 +193,7 @@ RDEPENDS_task-base-acpi = "\
acpid"
RDEPENDS_task-base-apm = "\
- apm \
+ "${DISTRO_apm}" \
apmd \
${@base_contains('MACHINE_FEATURES', 'kernel24', 'network-suspend-scripts', '',d)}"