aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/thc/hydra_4.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/thc/hydra_4.5.bb')
-rw-r--r--recipes/thc/hydra_4.5.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/thc/hydra_4.5.bb b/recipes/thc/hydra_4.5.bb
new file mode 100644
index 0000000000..fa7063687c
--- /dev/null
+++ b/recipes/thc/hydra_4.5.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "A very fast network logon cracker which support many different services"
+HOMEPAGE = "http://thc.org/thc-hydra/"
+SECTION = "console/network"
+DEPENDS = "openssl"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://thc.org/releases/hydra-${PV}-src.tar.gz"
+S = "${WORKDIR}/hydra-${PV}-src"
+
+inherit autotools
+
+do_configure() {
+ echo "Now that's a sucky build system..."
+ cp -f Makefile.am Makefile
+}
+
+BINARIES = "pw-inspector hydra"
+
+do_install() {
+ install -d ${D}${bindir}
+ for f in ${BINARIES}
+ do
+ install -m 0755 $f ${D}${bindir}
+ done
+}