aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti/gst-ducati_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ti/gst-ducati_git.bb')
-rw-r--r--recipes/ti/gst-ducati_git.bb21
1 files changed, 13 insertions, 8 deletions
diff --git a/recipes/ti/gst-ducati_git.bb b/recipes/ti/gst-ducati_git.bb
index dec9dcc581..49ac24457f 100644
--- a/recipes/ti/gst-ducati_git.bb
+++ b/recipes/ti/gst-ducati_git.bb
@@ -5,25 +5,26 @@ LICENSE = "LGPLv2.1"
inherit autotools
PV = "0.10.0"
-PR = "r2"
+PR = "r3"
PR_append = "+gitr${SRCREV}"
-SRCREV = "bd235864a96fe9fc06df69bc9fc457d0408d9756"
+SRCREV = "2c30e033e5014903a61ad9b483627ff2e320b35a"
SRC_URI = "git://github.com/robclark/gst-ducati.git;protocol=git \
- http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-0.10.31.tar.bz2;name=archive \
+ http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-0.10.32.tar.bz2;name=archive \
"
-SRC_URI[archive.md5sum] = "a21fb08bdb578d972c7c14e77da8fbb6"
-SRC_URI[archive.sha256sum] = "7f737e6d047c1ebeb4e1e0725fc377c5d9f12ee89186de7960be3cbba709ab84"
+SRC_URI[archive.md5sum] = "442bc3d37b8511a73379143e7531d726"
+SRC_URI[archive.sha256sum] = "3bf4e46a186ee9a1f5e212aaf651d67cffb4f5f05345a7c99ae71d5d992be133"
S = "${WORKDIR}/git"
acpaths = "-I m4 -I common/m4"
do_configure_prepend () {
- rm -rf ${S}/common ${S}/po
- cp -Rf ${WORKDIR}/gstreamer-0.10.31/common ${S}/
- cp -Rf ${WORKDIR}/gstreamer-0.10.31/po ${S}/
+
+ rm -rf ${S}/common ${S}/po
+ cp -Rf ${WORKDIR}/gstreamer-0.10.32/common ${S}/
+ cp -Rf ${WORKDIR}/gstreamer-0.10.32/po ${S}/
if test -f po/Makefile.in.in;
then
@@ -33,3 +34,7 @@ do_configure_prepend () {
patch -p0 < common/gettext.patch
}
+FILES_${PN} += "${libdir}/gstreamer-0.10/*.so ${sysconfdir} ${installdir}"
+FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.a ${libdir}/gstreamer-0.10/*.la"
+FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
+