aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti/matrix-gui_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ti/matrix-gui_svn.bb')
-rw-r--r--recipes/ti/matrix-gui_svn.bb30
1 files changed, 4 insertions, 26 deletions
diff --git a/recipes/ti/matrix-gui_svn.bb b/recipes/ti/matrix-gui_svn.bb
index e5fc01d7f2..4388d2815f 100644
--- a/recipes/ti/matrix-gui_svn.bb
+++ b/recipes/ti/matrix-gui_svn.bb
@@ -6,7 +6,7 @@ PRIORITY = "optional"
SRCREV = "58"
PV = "1.0"
-PR = "r13+svnr${SRCPV}"
+PR = "r14+svnr${SRCPV}"
SRC_URI = "svn://gforge.ti.com/svn/matrix_gui/;module=trunk;proto=https;user=anonymous;pswd='' \
file://0001-Disable-cursor-override-for-X11.patch;patch=1 \
@@ -18,32 +18,9 @@ S = "${WORKDIR}/trunk"
inherit qt4x11
-MATRIX_EXTRA_BINS = " \
- memInfo \
- networkSettings \
- runOGLES2Coverflow \
- runOGLES2Shaders \
- runOGLESChameleonMan \
- runOGLESVase \
- setopp1 \
- setopp2 \
- setopp3 \
- setopp4 \
- standby \
- sysSettings \
- taskInfo \
-"
-
do_install() {
install -d ${D}/${bindir}
install -m 0755 ${S}/matrix_gui ${D}/${bindir}
- for i in ${MATRIX_EXTRA_BINS}; do
- install -m 0755 ${S}/bin/${i} ${D}/${bindir}
- done
- install -d ${D}/${datadir}/matrix/html
- install -m 0644 ${S}/*.html ${D}/${datadir}/matrix/html/
- install -d ${D}/${datadir}/matrix/images
- install -m 0644 ${S}/images/*.png ${D}/${datadir}/matrix/images/
install -d ${D}${sysconfdir}/init.d/
install -c -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/matrix-gui
install -d ${D}/${sysconfdir}/xdg/autostart
@@ -51,9 +28,10 @@ do_install() {
}
FILES_${PN}-autostart = "${sysconfdir}/xdg/autostart/matrix-gui.desktop"
-FILES_${PN} += "${datadir}/matrix/*"
#Make autostart package depend on matrix-gui package. Doesn't make sense
#to install the autostart package without the underlying matrix-gui package.
-RDEPENDS_${PN}-autostart = "${PN}"
+RDEPENDS_${PN}-autostart += "${PN}"
PACKAGES =+ "${PN}-autostart"
+
+RDEPENDS_${PN} += "matrix-gui-common"