aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti/ti-ocf-crypto-module_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ti/ti-ocf-crypto-module_1.0.bb')
-rw-r--r--recipes/ti/ti-ocf-crypto-module_1.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes/ti/ti-ocf-crypto-module_1.0.bb b/recipes/ti/ti-ocf-crypto-module_1.0.bb
index 3f8f248d2e..92c6cb047c 100644
--- a/recipes/ti/ti-ocf-crypto-module_1.0.bb
+++ b/recipes/ti/ti-ocf-crypto-module_1.0.bb
@@ -17,6 +17,11 @@ inherit module
PR = "${MACHINE_KERNEL_PR}+svnr${SRCPV}"
+# Fix silly hardcodes, module.bbclass puts in the *correct* values
+do_compile_prepend() {
+ sed -i 's:ARCH=arm CROSS_COMPILE=arm-none-linux-gnueabi-::g' Makefile
+}
+
do_install () {
install -d ${D}/lib/modules/${KERNEL_VERSION}/crypto/ocf/
install -m 0755 ${S}/ocf_omap3_cryptok.ko ${D}/lib/modules/${KERNEL_VERSION}/crypto/ocf/