aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tor/tor-0.1.1.26/configure.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/tor/tor-0.1.1.26/configure.patch')
-rw-r--r--recipes/tor/tor-0.1.1.26/configure.patch126
1 files changed, 126 insertions, 0 deletions
diff --git a/recipes/tor/tor-0.1.1.26/configure.patch b/recipes/tor/tor-0.1.1.26/configure.patch
new file mode 100644
index 0000000000..dcd214feb2
--- /dev/null
+++ b/recipes/tor/tor-0.1.1.26/configure.patch
@@ -0,0 +1,126 @@
+diff -Naur tor-0.1.1.23/configure.in tor-0.1.1.23_patched/configure.in
+--- tor-0.1.1.23/configure.in 2006-07-30 06:40:28.000000000 +0200
++++ tor-0.1.1.23_patched/configure.in 2006-09-04 22:18:15.000000000 +0200
+@@ -169,38 +169,6 @@
+ fi
+ fi
+
+-AC_CACHE_CHECK([whether we need extra options to link libevent],
+- ac_cv_libevent_linker_option, [
+- saved_LDFLAGS="$LDFLAGS"
+- le_runs=no
+- linked_with=nothing
+- for le_extra in "" "-Wl,-R$le_libdir" "-R$le_libdir" ; do
+- LDFLAGS="$le_extra $saved_LDFLAGS"
+- AC_TRY_RUN([void *event_init(void);
+- int main(int c, char **v) {
+- event_init(); return 0;
+- }],
+- libevent_runs=yes, libevent_runs=no)
+- if test $libevent_runs = yes ; then
+- if test -z "$le_extra" ; then
+- ac_cv_libevent_linker_option='(none)'
+- else
+- ac_cv_libevent_linker_option=$le_extra
+- fi
+- le_runs=yes
+- break
+- fi
+- done
+- if test $le_runs = no ; then
+- AC_MSG_ERROR([Found linkable libevent in $ac_cv_libevent_dir, but it doesn't run, even with -R. Maybe specify another using --with-libevent-dir?])
+- fi
+- LDFLAGS="$saved_LDFLAGS"
+-])
+-
+-if test $ac_cv_libevent_linker_option != '(none)' ; then
+- LDFLAGS="$ac_cv_libevent_linker_option $LDFLAGS"
+-fi
+-
+ dnl ------------------------------------------------------
+ dnl Where do you live, openssl? And how do we call you?
+
+@@ -266,66 +234,6 @@
+ fi
+ fi
+
+-AC_CACHE_CHECK([whether we need extra options to link OpenSSL],
+- ac_cv_openssl_linker_option, [
+- saved_LDFLAGS="$LDFLAGS"
+- ssl_runs=no
+- linked_with=nothing
+- for ssl_extra in "" "-Wl,-R$ssl_libdir" "-R$ssl_libdir" ; do
+- LDFLAGS="$ssl_extra $saved_LDFLAGS"
+- AC_TRY_RUN([
+-#include <string.h>
+-#include <openssl/rand.h>
+-int main(void)
+-{
+- char a[2048];
+- memset(a, 0, sizeof(a));
+- RAND_add(a, sizeof(a), sizeof(a));
+- return(RAND_status() <= 0);
+-}
+- ],
+- openssl_runs=yes, openssl_runs=no)
+- if test $openssl_runs = yes ; then
+- if test "$linked_with" = nothing; then
+- linked_with="$ssl_extra"
+- fi
+- AC_TRY_RUN([
+-#include <openssl/opensslv.h>
+-#include <openssl/crypto.h>
+-int main(void) {
+-return (OPENSSL_VERSION_NUMBER == SSLeay()) == 0;
+-}],
+- right_version=yes, right_version=no)
+- if test "$right_version" = yes; then
+- if test -z "$ssl_extra" ; then
+- ac_cv_openssl_linker_option='(none)'
+- else
+- ac_cv_openssl_linker_option=$ssl_extra
+- fi
+- ssl_runs=yes
+- break
+- fi
+- fi
+- done
+- if test $ssl_runs = no ; then
+- if test "$linked_with" = 'nothing' ; then
+- AC_MSG_ERROR([Found linkable OpenSSL in $ac_cv_openssl_dir, but it doesn't run, even with -R. Maybe specify another using --with-ssl-dir?])
+- else
+- if test -z "$linked_with" ; then
+- ac_cv_openssl_linker_option='(none)'
+- else
+- ac_cv_openssl_linker_option=$linked_with
+- fi
+- AC_MSG_WARN([I managed to make OpenSSL link and run, but I couldn't make it link against the same version I found header files for.])
+- fi
+- fi
+- LDFLAGS="$saved_LDFLAGS"
+-])
+-
+-if test "$ac_cv_openssl_linker_option" != '(none)' ; then
+- LDFLAGS="$ac_cv_openssl_linker_option $LDFLAGS"
+-fi
+-
+ dnl Make sure to enable support for large off_t if avalable.
+
+ AC_SYS_LARGEFILE
+@@ -377,16 +285,6 @@
+ AC_CHECK_SIZEOF(__int64)
+ AC_CHECK_SIZEOF(void *)
+ AC_CHECK_SIZEOF(time_t)
+-AC_CACHE_CHECK([whether time_t is signed], tor_cv_time_t_signed, [
+-AC_TRY_RUN([
+-int main(int c, char**v) { if (((time_t)-1)<0) return 1; else return 0; }],
+- tor_cv_time_t_signed=no, tor_cv_time_t_signed=yes)
+-])
+-
+-if test $tor_cv_time_t_signed = yes; then
+- AC_DEFINE([TIME_T_IS_SIGNED], 1,
+- [Define to 1 iff time_t is signed])
+-fi
+
+ AC_CHECK_SIZEOF(socklen_t, , [AC_INCLUDES_DEFAULT()
+ #ifdef HAVE_SYS_SOCKET_H