summaryrefslogtreecommitdiffstats
path: root/recipes/toscoterm
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/toscoterm')
-rw-r--r--recipes/toscoterm/toscoterm_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/toscoterm/toscoterm_git.bb b/recipes/toscoterm/toscoterm_git.bb
new file mode 100644
index 0000000000..9826c9e9d1
--- /dev/null
+++ b/recipes/toscoterm/toscoterm_git.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "A very small and simple terminal emulator"
+SECTION = "x11/applications"
+LICENSE = "GPLv3"
+DEPENDS = "vte"
+HOMEPAGE = "https://projetos.ossystems.com.br/projects/show/toscoterm"
+PV = "0.0+gitr${SRCREV}"
+PR = "r3"
+
+SRC_URI = "git://projetos.ossystems.com.br/git/toscoterm.git;protocol=git"
+S = "${WORKDIR}/git"
+
+do_compile() {
+ oe_runmake \
+ CC="${CC}" \
+ CFLAGS="${CFLAGS} `pkg-config --cflags gtk+-2.0` `pkg-config --cflags vte`" \
+ LDFLAGS="${LDFLAGS} `pkg-config --libs gtk+-2.0` `pkg-config --libs vte`"
+}
+
+do_install() {
+ oe_runmake PREFIX="/usr" DESTDIR="${D}" install
+}