aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/totem/totem/gst-detect.diff
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/totem/totem/gst-detect.diff')
-rw-r--r--recipes/totem/totem/gst-detect.diff37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/totem/totem/gst-detect.diff b/recipes/totem/totem/gst-detect.diff
new file mode 100644
index 0000000000..6d37515995
--- /dev/null
+++ b/recipes/totem/totem/gst-detect.diff
@@ -0,0 +1,37 @@
+--- /tmp/configure.in 2008-08-10 15:27:06.000000000 +0200
++++ totem-2.23.4/configure.in 2008-08-10 20:37:08.743198000 +0200
+@@ -142,11 +142,7 @@
+ if $gst010_inspect $base_element >/dev/null 2>/dev/null; then
+ AC_MSG_RESULT([yes])
+ else
+- AC_MSG_RESULT([no])
+- AC_MSG_ERROR([
+- Cannot find required GStreamer-0.10 plugin '$base_element'.
+- It should be part of gst-plugins-base. Please install it.
+- ])
++ AC_MSG_RESULT([yes, we assume OE has already built them])
+ fi
+ done
+
+@@ -157,11 +153,7 @@
+ if $gst010_inspect $good_element >/dev/null 2>/dev/null; then
+ AC_MSG_RESULT([yes])
+ else
+- AC_MSG_RESULT([no])
+- AC_MSG_ERROR([
+- Cannot find required GStreamer-0.10 plugin '$good_element'.
+- It should be part of gst-plugins-good. Please install it.
+- ])
++ AC_MSG_RESULT([yes, we assume OE has already built them])
+ fi
+ done
+
+@@ -565,7 +557,7 @@
+ fi
+ ;;
+ mythtv)
+- PKG_CHECK_MODULES(GMYTH, gmyth >= 0.7 gmyth-upnp >= 0.7.1,
++ PKG_CHECK_MODULES(GMYTH, gmyth >= 0.7.0 gmyth-upnp,
+ [HAVE_GMYTH=yes], [HAVE_GMYTH=no])
+ if test "${HAVE_GMYTH}" != "yes"; then
+ plugin_error_or_ignore "you need GMyth >= 0.7 installed for the MythTV plugin"