aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tremor
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/tremor')
-rw-r--r--recipes/tremor/tremor_20041119.bb22
-rw-r--r--recipes/tremor/tremor_svn.bb20
2 files changed, 42 insertions, 0 deletions
diff --git a/recipes/tremor/tremor_20041119.bb b/recipes/tremor/tremor_20041119.bb
new file mode 100644
index 0000000000..de8ee927ea
--- /dev/null
+++ b/recipes/tremor/tremor_20041119.bb
@@ -0,0 +1,22 @@
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "libogg"
+DESCRIPTION = "tremor is a fixed point implementation of the vorbis codec."
+LICENSE = "BSD"
+SRCDATE = "${PV}"
+PR = "r1"
+
+# tremor makes heavy use of non-thumb-compatible inline asm.
+ARM_INSTRUCTION_SET = "arm"
+
+SRC_URI = "svn://svn.xiph.org/trunk;module=Tremor;rev=4573;proto=http"
+
+S = "${WORKDIR}/Tremor"
+
+inherit autotools
+
+EXTRA_OECONF=" --enable-shared --disable-rpath "
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/tremor/tremor_svn.bb b/recipes/tremor/tremor_svn.bb
new file mode 100644
index 0000000000..29851f55af
--- /dev/null
+++ b/recipes/tremor/tremor_svn.bb
@@ -0,0 +1,20 @@
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "libogg"
+DESCRIPTION = "tremor is a fixed point implementation of the vorbis codec."
+PV = "1:0.0+svn${SRCDATE}"
+LICENSE = "BSD"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "svn://svn.xiph.org/trunk;module=Tremor;proto=http"
+
+S = "${WORKDIR}/Tremor"
+
+inherit autotools
+
+EXTRA_OECONF=" --enable-shared --disable-rpath "
+
+do_stage() {
+ autotools_stage_all
+}