aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/txdrug/txdrug_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/txdrug/txdrug_0.1.bb')
-rw-r--r--recipes/txdrug/txdrug_0.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/txdrug/txdrug_0.1.bb b/recipes/txdrug/txdrug_0.1.bb
new file mode 100644
index 0000000000..31da8117f7
--- /dev/null
+++ b/recipes/txdrug/txdrug_0.1.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Tx Drug Database"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "sqlite"
+PR = "r3"
+
+SRC_URI = "http://teax.sourceforge.net/txdrug-${PV}.tar.gz \
+ file://${FILESDIR}/opt/QtPalmtop"
+S = "${WORKDIR}/txdrug-tar"
+
+inherit palmtop
+
+EXTRA_QMAKEVARS_POST += "LIBS+=-lsqlite TARGET=txdrug"
+
+do_configure_prepend() {
+ rm -f Makefile && qmake -project
+}
+
+do_configure_append() {
+ sed -i "s/\-I\/usr\/include\/sqlite\ //g" Makefile
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}
+ cp -Pfr `ls -dp ${WORKDIR}/opt/QtPalmtop/*|grep -v SCCS` ${D}${palmtopdir}/
+ install -D -m 755 txdrug ${D}${palmtopdir}/bin/txdrug
+}
+