aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/txdrug
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/txdrug')
-rw-r--r--recipes/txdrug/txdrug-0.1/opt/QtPalmtop/apps/Applications/txdrug.desktop6
-rwxr-xr-xrecipes/txdrug/txdrug-0.1/opt/QtPalmtop/etc/txdrug/drugs.dbbin0 -> 791552 bytes
-rw-r--r--recipes/txdrug/txdrug-0.1/opt/QtPalmtop/pics/txdrug.pngbin0 -> 2376 bytes
-rw-r--r--recipes/txdrug/txdrug-0.1/opt/QtPalmtop/pics/txdrug/down.pngbin0 -> 182 bytes
-rw-r--r--recipes/txdrug/txdrug-0.1/opt/QtPalmtop/pics/txdrug/up.pngbin0 -> 175 bytes
-rw-r--r--recipes/txdrug/txdrug_0.1.bb29
6 files changed, 35 insertions, 0 deletions
diff --git a/recipes/txdrug/txdrug-0.1/opt/QtPalmtop/apps/Applications/txdrug.desktop b/recipes/txdrug/txdrug-0.1/opt/QtPalmtop/apps/Applications/txdrug.desktop
new file mode 100644
index 0000000000..d3c4510192
--- /dev/null
+++ b/recipes/txdrug/txdrug-0.1/opt/QtPalmtop/apps/Applications/txdrug.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Comment = Drug Lookup
+Exec = txdrug
+Type = Application
+Icon = txdrug
+Name = TxDrug
diff --git a/recipes/txdrug/txdrug-0.1/opt/QtPalmtop/etc/txdrug/drugs.db b/recipes/txdrug/txdrug-0.1/opt/QtPalmtop/etc/txdrug/drugs.db
new file mode 100755
index 0000000000..336fa243c9
--- /dev/null
+++ b/recipes/txdrug/txdrug-0.1/opt/QtPalmtop/etc/txdrug/drugs.db
Binary files differ
diff --git a/recipes/txdrug/txdrug-0.1/opt/QtPalmtop/pics/txdrug.png b/recipes/txdrug/txdrug-0.1/opt/QtPalmtop/pics/txdrug.png
new file mode 100644
index 0000000000..9311f653b3
--- /dev/null
+++ b/recipes/txdrug/txdrug-0.1/opt/QtPalmtop/pics/txdrug.png
Binary files differ
diff --git a/recipes/txdrug/txdrug-0.1/opt/QtPalmtop/pics/txdrug/down.png b/recipes/txdrug/txdrug-0.1/opt/QtPalmtop/pics/txdrug/down.png
new file mode 100644
index 0000000000..b7aeaae9bc
--- /dev/null
+++ b/recipes/txdrug/txdrug-0.1/opt/QtPalmtop/pics/txdrug/down.png
Binary files differ
diff --git a/recipes/txdrug/txdrug-0.1/opt/QtPalmtop/pics/txdrug/up.png b/recipes/txdrug/txdrug-0.1/opt/QtPalmtop/pics/txdrug/up.png
new file mode 100644
index 0000000000..b637166778
--- /dev/null
+++ b/recipes/txdrug/txdrug-0.1/opt/QtPalmtop/pics/txdrug/up.png
Binary files differ
diff --git a/recipes/txdrug/txdrug_0.1.bb b/recipes/txdrug/txdrug_0.1.bb
new file mode 100644
index 0000000000..31da8117f7
--- /dev/null
+++ b/recipes/txdrug/txdrug_0.1.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Tx Drug Database"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "sqlite"
+PR = "r3"
+
+SRC_URI = "http://teax.sourceforge.net/txdrug-${PV}.tar.gz \
+ file://${FILESDIR}/opt/QtPalmtop"
+S = "${WORKDIR}/txdrug-tar"
+
+inherit palmtop
+
+EXTRA_QMAKEVARS_POST += "LIBS+=-lsqlite TARGET=txdrug"
+
+do_configure_prepend() {
+ rm -f Makefile && qmake -project
+}
+
+do_configure_append() {
+ sed -i "s/\-I\/usr\/include\/sqlite\ //g" Makefile
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}
+ cp -Pfr `ls -dp ${WORKDIR}/opt/QtPalmtop/*|grep -v SCCS` ${D}${palmtopdir}/
+ install -D -m 755 txdrug ${D}${palmtopdir}/bin/txdrug
+}
+