aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tximage/tximage_0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/tximage/tximage_0.2.bb')
-rw-r--r--recipes/tximage/tximage_0.2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/tximage/tximage_0.2.bb b/recipes/tximage/tximage_0.2.bb
new file mode 100644
index 0000000000..1911e4fb51
--- /dev/null
+++ b/recipes/tximage/tximage_0.2.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Tx Image Viewer"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://community.zaurus.com/projects/tximage/"
+PR = "r2"
+
+SRC_URI = "http://www.openzaurus.org/mirror/tximage-${PV}.tar.gz \
+ file://gcc3.patch;patch=1 \
+ file://gcc4.patch;patch=1"
+
+inherit palmtop
+
+do_install() {
+ install -d ${D}${palmtopdir}/apps/Applications \
+ ${D}${palmtopdir}/pics \
+ ${D}${palmtopdir}/bin
+ install -D -m 755 tximage ${D}${palmtopdir}/bin/tximage
+ install -D -m 644 imageviewer.desktop ${D}${palmtopdir}/apps/Applications/tximage.desktop
+ cp -pPR tximage.png ${D}${palmtopdir}/pics/
+}