aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot/u-boot_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/u-boot/u-boot_git.bb')
-rw-r--r--recipes/u-boot/u-boot_git.bb60
1 files changed, 49 insertions, 11 deletions
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index e44b8391f1..ed2ee9265b 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -1,5 +1,5 @@
require u-boot.inc
-PR ="r61"
+PR ="r62"
FILESPATHPKG =. "u-boot-git:"
@@ -76,22 +76,60 @@ SRC_URI_beagleboard = "git://www.denx.de/git/u-boot.git;protocol=git \
SRCREV_beagleboard = "ca6e1c136ddb720c3bb2cc043b99f7f06bc46c55"
PV_beagleboard = "2010.03+${PR}+gitr${SRCREV}"
-SRCREV_calamari = "533cf3a024947aaf74c16573a6d951cd0c3d0a7d"
+SRCREV_calamari = "1f932d68bf8c3bb5fec34dc5c5d654fc8614dd31"
-PV_calamari = "2009.11+${PR}+gitr${SRCREV}"
+PV_calamari = "2010.06+${PR}+gitr${SRCREV}"
SRC_URI_calamari = " \
git://git.denx.de/u-boot-mpc85xx.git;protocol=git \
- file://0002-cmd_itest.c-fix-pointer-dereferencing.patch \
- file://0001-cmd_i2c.c-reduced-subaddress-length-to-3-bytes.patch \
- file://0002-cmd_bootm.c-made-subcommand-array-static.patch \
- file://0003-cmd_i2c.c-reworked-subcommand-handling.patch \
- file://0004-cmd_i2c.c-sorted-commands-alphabetically.patch \
- file://0005-cmd_i2c.c-added-i2c-read-to-memory-function.patch \
- file://0007-cmd_setexpr-allow-memory-addresses-and-env-vars-in-e.patch \
+ file://fsl-esdhc.patch \
"
-UBOOT_MACHINE_calamari = "MPC8536DS_config"
+# calamari has different u-boot versions for nor, nand, sdcard and spiflash
+# build them all
+do_compile_calamari () {
+ unset LDFLAGS
+ unset CFLAGS
+ unset CPPFLAGS
+ oe_runmake MPC8536DS_config
+ oe_runmake all
+ mv u-boot.bin u-boot-nor.bin
+ oe_runmake clean
+ oe_runmake MPC8536DS_NAND_config
+ oe_runmake all
+ mv u-boot.bin u-boot-nand.bin
+ oe_runmake clean
+ oe_runmake MPC8536DS_SDCARD_config
+ oe_runmake all
+ mv u-boot.bin u-boot-sdcard.bin
+ oe_runmake clean
+ oe_runmake MPC8536DS_SPIFLASH_config
+ oe_runmake all
+ mv u-boot.bin u-boot-spiflash.bin
+ oe_runmake tools env
+}
+do_deploy_calamari () {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 ${S}/u-boot-nor.bin ${DEPLOY_DIR_IMAGE}/u-boot-nor.bin
+ install -m 0644 ${S}/u-boot-nand.bin ${DEPLOY_DIR_IMAGE}/u-boot-nand.bin
+ install -m 0644 ${S}/u-boot-sdcard.bin ${DEPLOY_DIR_IMAGE}/u-boot-sdcard.bin
+ install -m 0644 ${S}/u-boot-spiflash.bin ${DEPLOY_DIR_IMAGE}/u-boot-spiflash.bin
+ install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/uboot-mkimage
+}
+
+do_install_calamari () {
+ install -d ${D}/boot
+ install ${S}/u-boot-nor.bin ${D}/boot/u-boot-nor.bin
+ install ${S}/u-boot-nand.bin ${D}/boot/u-boot-nand.bin
+ install ${S}/u-boot-sdcard.bin ${D}/boot/u-boot-sdcard.bin
+ install ${S}/u-boot-spiflash.bin ${D}/boot/u-boot-spiflash.bin
+ ln -sf ${UBOOT_IMAGE} ${D}/boot/${UBOOT_BINARY}
+
+ install -d ${D}${base_sbindir}
+ install -d ${D}${sysconfdir}
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
+}
SRC_URI_omap3-touchbook = "git://gitorious.org/u-boot-omap3/mainline.git;branch=omap3-dev;protocol=git \
file://fw_env.config \
file://dss2.patch \