summaryrefslogtreecommitdiffstats
path: root/recipes/uicmoc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/uicmoc')
-rw-r--r--recipes/uicmoc/uicmoc-native_2.3.10.bb13
1 files changed, 8 insertions, 5 deletions
diff --git a/recipes/uicmoc/uicmoc-native_2.3.10.bb b/recipes/uicmoc/uicmoc-native_2.3.10.bb
index c161571d82..12f10a0952 100644
--- a/recipes/uicmoc/uicmoc-native_2.3.10.bb
+++ b/recipes/uicmoc/uicmoc-native_2.3.10.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.trolltech.com"
SECTION = "devel"
PRIORITY = "optional"
LICENSE = "GPL QPL"
-PR = "r4"
+PR = "r5"
SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-${PV}-free.tar.gz \
file://fix-makefile.patch \
@@ -43,11 +43,14 @@ do_compile() {
oe_runmake -C tools/makeqpf || die "Building makeqpf failed"
}
-do_stage() {
- install -m 0755 bin/moc ${STAGING_BINDIR}
- install -m 0755 bin/uic ${STAGING_BINDIR}
- install -m 0755 tools/makeqpf/makeqpf ${STAGING_BINDIR}
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 bin/moc ${D}${bindir}
+ install -m 0755 bin/uic ${D}${bindir}
+ install -m 0755 tools/makeqpf/makeqpf ${D}${bindir}
}
SRC_URI[md5sum] = "1f7ad30113afc500cab7f5b2f4dec0d7"
SRC_URI[sha256sum] = "883363eb0c94de3d1e36f3ab9e09a8f127418d497213cc1a0ed1a1588ecd66b8"
+
+NATIVE_INSTALL_WORKS = "1"