aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/unrar
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/unrar')
-rw-r--r--recipes/unrar/unrar-native_3.4.3.bb14
-rw-r--r--recipes/unrar/unrar.inc7
-rw-r--r--recipes/unrar/unrar_3.4.3.bb6
3 files changed, 27 insertions, 0 deletions
diff --git a/recipes/unrar/unrar-native_3.4.3.bb b/recipes/unrar/unrar-native_3.4.3.bb
new file mode 100644
index 0000000000..4b87691e89
--- /dev/null
+++ b/recipes/unrar/unrar-native_3.4.3.bb
@@ -0,0 +1,14 @@
+require unrar.inc
+inherit native
+
+do_stage() {
+ install unrar ${STAGING_BINDIR}
+}
+
+do_package() {
+ :
+}
+
+do_install() {
+ :
+}
diff --git a/recipes/unrar/unrar.inc b/recipes/unrar/unrar.inc
new file mode 100644
index 0000000000..4887ac9fb2
--- /dev/null
+++ b/recipes/unrar/unrar.inc
@@ -0,0 +1,7 @@
+SRC_URI = "http://www.rarlab.com/rar/unrarsrc-${PV}.tar.gz"
+S = "${WORKDIR}/unrar"
+
+do_compile() {
+ oe_runmake -f makefile.unix
+}
+
diff --git a/recipes/unrar/unrar_3.4.3.bb b/recipes/unrar/unrar_3.4.3.bb
new file mode 100644
index 0000000000..39d81990e2
--- /dev/null
+++ b/recipes/unrar/unrar_3.4.3.bb
@@ -0,0 +1,6 @@
+require unrar.inc
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 unrar ${D}${bindir}
+}