summaryrefslogtreecommitdiffstats
path: root/recipes/ushare/ushare_hg.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ushare/ushare_hg.bb')
-rw-r--r--recipes/ushare/ushare_hg.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/ushare/ushare_hg.bb b/recipes/ushare/ushare_hg.bb
new file mode 100644
index 0000000000..0e24cfb8fb
--- /dev/null
+++ b/recipes/ushare/ushare_hg.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "ushare is a UPnP media server"
+LICENSE = "GPL"
+HOMEPAGE = "http://ushare.geexbox.org/"
+DEPENDS = "gamin libdlna libupnp virtual/libiconv virtual/libintl"
+
+PV = "1.1a"
+PR = "r1"
+PR_append = "+hg${SRCPV}"
+SRCREV = "2e40e513a4a0"
+
+SRC_URI = "hg://hg.geexbox.org;proto=http;module=ushare;rev=${SRCREV} \
+"
+
+S= "${WORKDIR}/ushare"
+
+inherit autotools gettext
+
+# the configure script is hand-crafted, it rejects some of the usual
+# configure arguments
+do_configure () {
+ ${S}/configure \
+ --prefix=${prefix} \
+ --bindir=${bindir} \
+ --localedir=${datadir}/locale \
+ --sysconfdir=${sysconfdir} \
+ --disable-strip \
+ --enable-fam \
+ --cross-compile
+}
+