aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/watchdog/watchdog_5.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/watchdog/watchdog_5.6.bb')
-rw-r--r--recipes/watchdog/watchdog_5.6.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/recipes/watchdog/watchdog_5.6.bb b/recipes/watchdog/watchdog_5.6.bb
index 8c0845f0d7..569a1b2429 100644
--- a/recipes/watchdog/watchdog_5.6.bb
+++ b/recipes/watchdog/watchdog_5.6.bb
@@ -1,9 +1,14 @@
DESCRIPTION = "System watchdog daemon"
LICENSE = "GPL"
+PR = "r1"
SRC_URI = "http://www.ibiblio.org/pub/Linux/system/daemons/watchdog/${PN}-${PV}.tar.gz \
file://init"
+SRC_URI_append_nokia900 = " \
+ file://watchdog.conf \
+ file://watchdog-omap.conf"
+
inherit autotools update-rc.d
INITSCRIPT_NAME = "watchdog"
@@ -14,6 +19,11 @@ do_install_append() {
install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/watchdog
}
+do_install_append_nokia900() {
+ install -m 0644 ${WORKDIR}/watchdog.conf ${D}${sysconfdir}/watchdog.conf
+ install -m 0644 ${WORKDIR}/watchdog-omap.conf ${D}${sysconfdir}/watchdog-omap.conf
+}
+
SRC_URI[md5sum] = "6df285569dd1d85528b983c98c9b2b7c"
SRC_URI[sha256sum] = "a2c7d6726e092315dbb047211b754528e4532521678a30e16f60a31bb86a7f74"