aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/webkit/webkit-gtk/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/webkit/webkit-gtk/configure.ac')
-rw-r--r--recipes/webkit/webkit-gtk/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes/webkit/webkit-gtk/configure.ac b/recipes/webkit/webkit-gtk/configure.ac
index 2ee8210695..19ce1eb553 100644
--- a/recipes/webkit/webkit-gtk/configure.ac
+++ b/recipes/webkit/webkit-gtk/configure.ac
@@ -494,6 +494,10 @@ AC_ARG_ENABLE([jit],
[],[enable_jit="yes"])
if test "$enable_jit" = "yes"; then
case "$host_cpu" in
+ arm)
+ AC_DEFINE([ENABLE_JIT_OPTIMIZE_CALL], [1], [Define to enable optimizing calls])
+ AC_DEFINE([ENABLE_JIT_OPTIMIZE_METHOD_CALLS], [1], [Define to enable optimizing method calls])
+ ;;
i*86|x86_64)
AC_DEFINE([ENABLE_JIT], [1], [Define to enable JIT])
AC_DEFINE([ENABLE_YARR], [1], [Define to enable YARR])