aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wget/wget_1.9.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/wget/wget_1.9.1.bb')
-rw-r--r--recipes/wget/wget_1.9.1.bb41
1 files changed, 10 insertions, 31 deletions
diff --git a/recipes/wget/wget_1.9.1.bb b/recipes/wget/wget_1.9.1.bb
index b1e9404c01..50974ed87b 100644
--- a/recipes/wget/wget_1.9.1.bb
+++ b/recipes/wget/wget_1.9.1.bb
@@ -1,40 +1,19 @@
-DESCRIPTION = "A console URL download utility featuring HTTP, FTP, and more."
-SECTION = "console/network"
-DEPENDS = ""
-PR = "r7"
-LICENSE = "GPL"
+PR = "${INC_PR}.1"
-SRC_URI = "${GNU_MIRROR}/wget/wget-${PV}.tar.gz \
- file://m4macros.patch;patch=1 \
- file://autotools.patch;patch=1 \
- file://ipv6-fix.patch;patch=1"
-S = "${WORKDIR}/wget-${PV}"
-
-inherit autotools gettext
-
-# Disable checking for SSL since that searches the system paths
-EXTRA_OECONF = "--enable-ipv6 --without-ssl"
+SRC_URI = " \
+ ${GNU_MIRROR}/wget/wget-${PV}.tar.gz \
+ file://m4macros.patch;patch=1 \
+ file://autotools.patch;patch=1 \
+ file://ipv6-fix.patch;patch=1 \
+"
-# SlugOS kernels do not support ipv6. Can be loaded as a module.
-EXTRA_OECONF_slugos = "--without-ssl"
+S = "${WORKDIR}/wget-${PV}"
-do_configure () {
+do_configure_prepend () {
if [ ! -e acinclude.m4 ]; then
mv aclocal.m4 acinclude.m4
fi
rm -f libtool.m4
- autotools_do_configure
}
-do_install () {
- autotools_do_install
- mv ${D}${bindir}/wget ${D}${bindir}/wget.${PN}
-}
-
-pkg_postinst_${PN} () {
- update-alternatives --install ${bindir}/wget wget wget.${PN} 100
-}
-
-pkg_prerm_${PN} () {
- update-alternatives --remove wget wget.${PN}
-}
+require wget.inc