aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/whois
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/whois')
-rw-r--r--recipes/whois/whois.inc21
-rw-r--r--recipes/whois/whois_4.5.25.bb6
2 files changed, 27 insertions, 0 deletions
diff --git a/recipes/whois/whois.inc b/recipes/whois/whois.inc
new file mode 100644
index 0000000000..15af5e8454
--- /dev/null
+++ b/recipes/whois/whois.inc
@@ -0,0 +1,21 @@
+DEPENDS += "gettext-native virtual/libintl"
+DESCRIPTION = "whois is an improved whois client"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.linux.it/~md/software/"
+SECTION = "network"
+
+def whois_intl(bb, d):
+ # FIXME: This is ugly.. we already have the virtual for this,
+ # but there's no way to ask bb who the current selected provider of
+ # a given virtual/ is.
+ if (bb.data.getVar('TARGET_OS', d, 1) or '').endswith('-uclibc'):
+ return ' -lintl'
+ return ''
+
+EXTRA_OEMAKE = '"OPTS=${CFLAGS} -DCONFIG_FILE=\\\"/etc/whois.conf\\\"" \
+ "CC=${CC}" "LDFLAGS=${LDFLAGS}${@whois_intl(bb, d)}"'
+
+do_install () {
+ install -D -m 0755 whois ${D}${bindir}/whois
+ install -D -m 0644 whois.1 ${D}${mandir}/man1/whois.1
+}
diff --git a/recipes/whois/whois_4.5.25.bb b/recipes/whois/whois_4.5.25.bb
new file mode 100644
index 0000000000..22952b0d8c
--- /dev/null
+++ b/recipes/whois/whois_4.5.25.bb
@@ -0,0 +1,6 @@
+require whois.inc
+
+SRC_URI = "${DEBIAN_MIRROR}/main/w/whois/whois_${PV}.tar.gz"
+S = "${WORKDIR}/whois-${PV}"
+
+inherit gettext