aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wlan-ng/wlan-ng-utils
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/wlan-ng/wlan-ng-utils')
-rw-r--r--recipes/wlan-ng/wlan-ng-utils/config.in21
-rw-r--r--recipes/wlan-ng/wlan-ng-utils/hostldflags.patch20
-rw-r--r--recipes/wlan-ng/wlan-ng-utils/only-the-utils.patch33
-rw-r--r--recipes/wlan-ng/wlan-ng-utils/wlan.agent105
4 files changed, 179 insertions, 0 deletions
diff --git a/recipes/wlan-ng/wlan-ng-utils/config.in b/recipes/wlan-ng/wlan-ng-utils/config.in
new file mode 100644
index 0000000000..cac5576f34
--- /dev/null
+++ b/recipes/wlan-ng/wlan-ng-utils/config.in
@@ -0,0 +1,21 @@
+WLAN_VERSION=0
+WLAN_PATCHLEVEL=2
+WLAN_SUBLEVEL=3
+WLAN_EXTRAVERSION=svn
+#LINUX_SRC=$(KERNEL_SOURCE)
+PCMCIA_SRC=.
+PREFIX=
+INST_EXEDIR=/sbin
+#TARGET_ROOT_ON_HOST=
+#RC_DIR=/etc/init.d
+PCMCIA_DIR=/etc/pcmcia
+SYSV_INIT=y
+INSTALL_DEPMOD=
+WLAN_DEBUG=n
+CROSS_COMPILE_ENABLED=n
+CROSS_COMPILE=
+HOST_COMPILE=
+PRISM2_PLX=y
+PRISM2_PCMCIA=y
+PRISM2_PCI=y
+PRISM2_USB=y
diff --git a/recipes/wlan-ng/wlan-ng-utils/hostldflags.patch b/recipes/wlan-ng/wlan-ng-utils/hostldflags.patch
new file mode 100644
index 0000000000..93893a5e11
--- /dev/null
+++ b/recipes/wlan-ng/wlan-ng-utils/hostldflags.patch
@@ -0,0 +1,20 @@
+Index: linux-wlan-ng-0.2.3/src/mkmeta/Makefile
+===================================================================
+--- linux-wlan-ng-0.2.3.orig/src/mkmeta/Makefile 2005-01-26 23:01:07.000000000 +0100
++++ linux-wlan-ng-0.2.3/src/mkmeta/Makefile 2006-04-18 22:07:58.937819216 +0200
+@@ -90,13 +90,13 @@
+
+
+ mkmetadef: $(MKMETADEF_OBJ) mkmetadefhead.txt
+- $(HOST_CC) $(LDFLAGS) -o $@ $(MKMETADEF_OBJ)
++ $(HOST_CC) $(HOST_LDFLAGS) -o $@ $(MKMETADEF_OBJ)
+ cat mkmetadefhead.txt > ../include/wlan/p80211metadef.h
+ ./mkmetadef >> ../include/wlan/p80211metadef.h
+ echo "#endif" >> ../include/wlan/p80211metadef.h
+
+ mkmetastruct: $(MKMETASTRUCT_OBJ) mkmetastructhead.txt
+- $(HOST_CC) $(LDFLAGS) -o $@ $(MKMETASTRUCT_OBJ)
++ $(HOST_CC) $(HOST_LDFLAGS) -o $@ $(MKMETASTRUCT_OBJ)
+ cat mkmetastructhead.txt > ../include/wlan/p80211metastruct.h
+ ./mkmetastruct >> ../include/wlan/p80211metastruct.h
+ echo "#endif" >> ../include/wlan/p80211metastruct.h
diff --git a/recipes/wlan-ng/wlan-ng-utils/only-the-utils.patch b/recipes/wlan-ng/wlan-ng-utils/only-the-utils.patch
new file mode 100644
index 0000000000..5e0eb46cef
--- /dev/null
+++ b/recipes/wlan-ng/wlan-ng-utils/only-the-utils.patch
@@ -0,0 +1,33 @@
+Index: linux-wlan-ng-devel/src/Makefile
+===================================================================
+--- linux-wlan-ng-devel.orig/src/Makefile 2006-02-21 11:41:23.000000000 +0100
++++ linux-wlan-ng-devel/src/Makefile 2006-02-21 13:15:30.836085080 +0100
+@@ -44,10 +44,11 @@
+
+ -include ../config.mk
+
+-DIRS=p80211 prism2 shared wlanctl nwepgen \
+- mkmeta wlancfg
+-ALL_DIRS=mkmeta p80211 prism2 shared wlanctl \
+- nwepgen wlancfg
++
++DIRS=prism2 shared wlanctl nwepgen \
++ mkmeta wlancfg
++ALL_DIRS=mkmeta prism2 shared wlanctl \
++ nwepgen wlancfg
+
+ ifneq ($(wildcard *.addon),)
+ DIRS+=`cat *.addon`
+Index: linux-wlan-ng-devel/src/prism2/Makefile
+===================================================================
+--- linux-wlan-ng-devel.orig/src/prism2/Makefile 2006-02-21 11:41:23.000000000 +0100
++++ linux-wlan-ng-devel/src/prism2/Makefile 2006-02-21 13:14:43.248319520 +0100
+@@ -44,7 +44,7 @@
+
+ -include ../../config.mk
+
+-DIRS=driver ridlist download
++DIRS=ridlist download
+
+ ifneq ($(wildcard *.addon),)
+ DIRS+=`cat *.addon`
diff --git a/recipes/wlan-ng/wlan-ng-utils/wlan.agent b/recipes/wlan-ng/wlan-ng-utils/wlan.agent
new file mode 100644
index 0000000000..d7124f3816
--- /dev/null
+++ b/recipes/wlan-ng/wlan-ng-utils/wlan.agent
@@ -0,0 +1,105 @@
+#!/bin/sh
+#
+# p80211/wlan hotplug policy agent.
+#
+# wlan hotplug params include:
+#
+# ACTION=%s [register|remove|shutdown|startup|suspend|resume]
+# INTERFACE=%s
+# NSDNAME=%s
+#
+
+cd /etc/hotplug
+# must have ./ here or busybox shell barfs
+. ./hotplug.functions
+
+#DEBUG=yes export DEBUG
+
+if [ "$INTERFACE" = "" ]; then
+ mesg Bad WLAN invocation: \$INTERFACE is not set
+ exit 1
+fi
+
+if [ "$NSDNAME" = "" ]; then
+ mesg Bad WLAN invocation: \$NSDNAME is not set
+ exit 1
+fi
+
+debug_mesg WLAN $ACTION on $INTERFACE \($NSDNAME\)
+
+if [ "$NSDNAME" = "prism2_cs" ] ; then
+ mesg "WLAN Hotplug bypassed for pcmcia"
+ exit 0
+fi
+
+# load up the shared scripts
+if [ ! -f /etc/wlan/shared ] ; then
+ mesg "/etc/wlan/shared not present, aborting"
+ exit 1
+fi
+
+ECHO=mesg
+. /etc/wlan/shared
+
+case $ACTION in
+'register'|'resume')
+ eval 'WLAN_ENABLE=$ENABLE_'$INTERFACE
+ if ! is_true $WLAN_ENABLE ; then
+ mesg "WLAN $ACTION - interface $INTERFACE not enabled, aborting"
+ exit 1
+ fi
+ debug_mesg WLAN $INTERFACE registered.
+ wlan_bring_it_up $INTERFACE
+ if [ $? = 0 ] ; then
+ mesg WLAN $INTERFACE brought up successfully.
+ if [ -x /etc/wlan/network ] ; then
+ mesg "WLAN bringing up layer 3+ with /etc/wlan/network"
+ /etc/wlan/network start $INTERFACE
+ elif [ -x /etc/wlan/pre-ifup ] ; then
+ # pre-ifup is presumed to call ifup if it
+ # wants to...it may choose to skip it.
+ mesg "WLAN bringing up layer 3+ with /etc/wlan/pre-ifup"
+ /etc/wlan/pre-ifup $INTERFACE
+ else
+ mesg "WLAN bringing up layer 3+ with /sbin/ifup"
+ /sbin/ifup $INTERFACE
+ fi
+ else
+ mesg WLAN Could not bring up $INTERFACE
+ exit 1
+ fi
+ # eventually invoke net.agent on $INTERFACE w/ REGISTER
+;;
+'remove'|'suspend')
+ debug_mesg WLAN $INTERFACE removed.
+ eval 'WLAN_ENABLE=$ENABLE_'$INTERFACE
+ if ! is_true $WLAN_ENABLE ; then
+ mesg "WLAN $ACTION - interface $INTERFACE not enabled, aborting"
+ exit 1
+ fi
+ if [ -x /etc/wlan/network ] ; then
+ mesg "WLAN taking down layer 3+ with /etc/wlan/network"
+ /etc/wlan/network stop $INTERFACE
+ elif [ -x /etc/wlan/post-ifdown ] ; then
+ # post-ifdown is presumed to call ifdown if it
+ # wants to...it may choose to skip it.
+ mesg "WLAN taking down layer 3+ with /etc/wlan/post-ifdown"
+ /etc/wlan/post-ifdown $INTERFACE
+ else
+ mesg "WLAN taking down layer 3+ with /sbin/ifdown"
+ /sbin/ifdown $INTERFACE
+ fi
+ wlan_disable $INTERFACE
+;;
+'startup')
+ # kick off wland.
+ debug_mesg WLAN p80211 starting!
+;;
+'shutdown')
+ debug_mesg WLAN p80211 shutting down!
+;;
+*)
+ debug_mesg WLAN $ACTION event not supported
+ exit 1 ;;
+
+esac