aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/woodstox
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/woodstox')
-rw-r--r--recipes/woodstox/woodstox2_2.0.6.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/woodstox/woodstox2_2.0.6.bb b/recipes/woodstox/woodstox2_2.0.6.bb
new file mode 100644
index 0000000000..390c4ff3f0
--- /dev/null
+++ b/recipes/woodstox/woodstox2_2.0.6.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "High-performance XML processor."
+LICENSE = "AL2.0 LGPL2.1"
+
+AUTHOR = "Codehaus"
+HOMEPAGE = "http://woodstox.codehaus.org"
+
+SRC_URI = "http://woodstox.codehaus.org/2.0.6/wstx-src.tar.gz"
+
+S = "${WORKDIR}"
+
+inherit java-library
+
+DEPENDS = "fastjar-native"
+
+do_compile() {
+ mkdir -p build/META-INF/services
+
+ javac -nowarn -sourcepath src/java -d build \
+ `find src/java/org -name "*.java"` \
+ `find src/java/com -name "*.java"`
+
+ cp -r src/resources/* build/META-INF/services
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}