aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wordlist/scowl_6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/wordlist/scowl_6.bb')
-rw-r--r--recipes/wordlist/scowl_6.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/wordlist/scowl_6.bb b/recipes/wordlist/scowl_6.bb
new file mode 100644
index 0000000000..46e312e059
--- /dev/null
+++ b/recipes/wordlist/scowl_6.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "SCOWL (Spell Checker Oriented Word Lists) is a collection of word lists split up in various sizes, and other categories, intended to be suitable for use in spell checkers. However, I am sure it will have numerous other uses as well."
+HOMEPAGE = "http://wordlist.sourceforge.net/"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/wordlist/scowl-6.tar.gz \
+ file://rules"
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+do_compile() {
+ cp -f ${WORKDIR}/rules ${S}
+ oe_runmake -f rules build
+}
+do_install() {
+ install -d ${D}/${datadir}/dict
+ install ${S}/american-english ${D}/${datadir}/dict
+ install ${S}/british-english ${D}/${datadir}/dict
+ install ${S}/canadian-english ${D}/${datadir}/dict
+}
+
+PACKAGE_ARCH = "all"
+PACKAGES = "wamerican wbritish wcanadian"
+
+FILES = "${datadir}/dict/${DICTNAME}"
+
+pkg_postinst() {
+#!/bin/sh
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+cd ${datadir}/dict
+ln -sf ${DICTNAME} words
+}
+
+DICTNAME_wamerican = "american-english"
+DICTNAME_wbritish = "british-english"
+DICTNAME_wcanadian = "canadian-english"