aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wrt/wrt-imagetools-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/wrt/wrt-imagetools-native.bb')
-rw-r--r--recipes/wrt/wrt-imagetools-native.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/wrt/wrt-imagetools-native.bb b/recipes/wrt/wrt-imagetools-native.bb
new file mode 100644
index 0000000000..f9f459eea6
--- /dev/null
+++ b/recipes/wrt/wrt-imagetools-native.bb
@@ -0,0 +1,17 @@
+#SRC_URI = "svn://svn.openwrt.org/openwrt;module=trunk/tools/firmware-utils/src;proto=https"
+SRC_URI = ${SOURCEFORGE_MIRROR}/gakusei/openwrt-imagetools-svn-rev7641.tar.bz2
+S = "${WORKDIR}/src/"
+
+inherit native
+
+do_compile() {
+ ${CC} -o trx trx.c
+ ${CC} -o motorola-bin motorola-bin.c
+ ${CC} -o addpattern addpattern.c
+}
+
+do_stage() {
+ install -m 0755 ${S}/trx ${STAGING_BINDIR}
+ install -m 0755 ${S}/motorola-bin ${STAGING_BINDIR}
+ install -m 0755 ${S}/addpattern ${STAGING_BINDIR}
+}