aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xapian
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/xapian')
-rw-r--r--recipes/xapian/xapian-core-native_1.0.5.bb5
-rw-r--r--recipes/xapian/xapian-core_1.0.5.bb16
-rw-r--r--recipes/xapian/xapian-core_1.0.7.bb16
-rw-r--r--recipes/xapian/xapian-quickstart.inc20
-rw-r--r--recipes/xapian/xapian-quickstartindex-native_1.0.bb9
-rw-r--r--recipes/xapian/xapian-quickstartindex_1.0.bb4
-rw-r--r--recipes/xapian/xapian-quickstartsearch_1.0.bb4
7 files changed, 74 insertions, 0 deletions
diff --git a/recipes/xapian/xapian-core-native_1.0.5.bb b/recipes/xapian/xapian-core-native_1.0.5.bb
new file mode 100644
index 0000000000..d3c425f6c4
--- /dev/null
+++ b/recipes/xapian/xapian-core-native_1.0.5.bb
@@ -0,0 +1,5 @@
+require xapian-core_${PV}.bb
+
+inherit native
+
+S = "${WORKDIR}/xapian-core-${PV}"
diff --git a/recipes/xapian/xapian-core_1.0.5.bb b/recipes/xapian/xapian-core_1.0.5.bb
new file mode 100644
index 0000000000..2af709324f
--- /dev/null
+++ b/recipes/xapian/xapian-core_1.0.5.bb
@@ -0,0 +1,16 @@
+DESCRPITION = "Open Source Search Engine Library"
+HOMEPAGE = "http://xapian.org"
+SECTION = "devel/libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "zlib"
+PR = "r0"
+
+SRC_URI = "http://www.oligarchy.co.uk/xapian/1.0.5/xapian-core-${PV}.tar.gz"
+
+inherit autotools
+
+do_stage () {
+ autotools_stage_all
+}
+
diff --git a/recipes/xapian/xapian-core_1.0.7.bb b/recipes/xapian/xapian-core_1.0.7.bb
new file mode 100644
index 0000000000..289cae4ead
--- /dev/null
+++ b/recipes/xapian/xapian-core_1.0.7.bb
@@ -0,0 +1,16 @@
+DESCRPITION = "Open Source Search Engine Library"
+HOMEPAGE = "http://xapian.org"
+SECTION = "devel/libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "zlib"
+PR = "r0"
+
+SRC_URI = "http://www.oligarchy.co.uk/xapian/${PV}/xapian-core-${PV}.tar.gz"
+
+inherit autotools
+
+do_stage () {
+ autotools_stage_all
+}
+
diff --git a/recipes/xapian/xapian-quickstart.inc b/recipes/xapian/xapian-quickstart.inc
new file mode 100644
index 0000000000..aab599f64b
--- /dev/null
+++ b/recipes/xapian/xapian-quickstart.inc
@@ -0,0 +1,20 @@
+DESCRIPTION = "Simplest possible indexer (from an older release of xapian)."
+HOMEPAGE = "http://users.softlab.ece.ntua.gr/~ttsiod/buildWikipediaOffline.html"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "xapian-core"
+
+BINARY_NAME = ${@bb.data.getVar("PN",d,1).replace("xapian-","").replace("-native","")}
+S = "${WORKDIR}"
+
+SRC_URI = "http://users.softlab.ece.ntua.gr/~ttsiod/${BINARY_NAME}.cc"
+
+do_compile() {
+ ${CXX} ${CXXLAGS} ${LDFLAGS} -I${STAGING_INCDIR_NATIVE} -lxapian -o ${BINARY_NAME} ${BINARY_NAME}.cc
+}
+
+do_install() {
+ install -d ${D}$
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/${BINARY_NAME} ${D}${bindir}/
+}
diff --git a/recipes/xapian/xapian-quickstartindex-native_1.0.bb b/recipes/xapian/xapian-quickstartindex-native_1.0.bb
new file mode 100644
index 0000000000..fe84d4cbf5
--- /dev/null
+++ b/recipes/xapian/xapian-quickstartindex-native_1.0.bb
@@ -0,0 +1,9 @@
+require xapian-quickstartindex_${PV}.bb
+
+DEPENDS = "xapian-core-native"
+
+inherit native
+
+do_stage() {
+ install -m 0744 ${WORKDIR}/${BINARY_NAME} ${STAGING_BINDIR}
+}
diff --git a/recipes/xapian/xapian-quickstartindex_1.0.bb b/recipes/xapian/xapian-quickstartindex_1.0.bb
new file mode 100644
index 0000000000..7a17f7b354
--- /dev/null
+++ b/recipes/xapian/xapian-quickstartindex_1.0.bb
@@ -0,0 +1,4 @@
+require xapian-quickstart.inc
+
+DESCRIPTION += "This package provides the tool for creating the index."
+PR = "r1"
diff --git a/recipes/xapian/xapian-quickstartsearch_1.0.bb b/recipes/xapian/xapian-quickstartsearch_1.0.bb
new file mode 100644
index 0000000000..c3381f6abd
--- /dev/null
+++ b/recipes/xapian/xapian-quickstartsearch_1.0.bb
@@ -0,0 +1,4 @@
+require xapian-quickstart.inc
+
+DESCRIPTION += "This package provides the tool for searching the index."
+PR = "r1"