aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xfce/xfce-mcs-manager_4.4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/xfce/xfce-mcs-manager_4.4.2.bb')
-rw-r--r--recipes/xfce/xfce-mcs-manager_4.4.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/xfce/xfce-mcs-manager_4.4.2.bb b/recipes/xfce/xfce-mcs-manager_4.4.2.bb
new file mode 100644
index 0000000000..0b9fc43f70
--- /dev/null
+++ b/recipes/xfce/xfce-mcs-manager_4.4.2.bb
@@ -0,0 +1,25 @@
+# xfce-mcs-manager OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see COPYING.MIT)
+
+DESCRIPTION="XFCE4 Settings manager."
+DEPENDS="libxfcegui4 libxfce4mcs intltool-native"
+SECTION = "x11"
+PR = "r1"
+
+inherit xfce
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/xfce4
+ install -d ${STAGING_INCDIR}/xfce4/xfce-mcs-manager
+ install -m 644 xfce-mcs-manager/manager-plugin.h ${STAGING_INCDIR}/xfce4/xfce-mcs-manager
+}
+
+# xfce-mcs-manager.pc uses ${libdir} to indicate where the mcs plugins live
+# the standard pkgconfig mangling was confusing us. Mangling is not required
+# for this particular .pc, so the following will suffice:
+
+do_stage_append () {
+ install -d ${PKG_CONFIG_DIR}
+ sed -e 's:^includedir=.*:includedir="/usr/include":;' ${S}/xfce-mcs-manager/xfce-mcs-manager.pc >${PKG_CONFIG_DIR}/xfce-mcs-manager.pc
+}