aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zgscore/zgscore_1.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/zgscore/zgscore_1.0.2.bb')
-rw-r--r--recipes/zgscore/zgscore_1.0.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/zgscore/zgscore_1.0.2.bb b/recipes/zgscore/zgscore_1.0.2.bb
new file mode 100644
index 0000000000..967791e53f
--- /dev/null
+++ b/recipes/zgscore/zgscore_1.0.2.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Zaurus Golf Score Application for Qt/Embedded based Palmtop Environments"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://nuke.cinlug.org/modules/Static_Docs/data/db/zgs/"
+PR = "r0"
+
+SRC_URI = "http://www.cinlug.org/modules/Static_Docs/data/db/zgs/zgscore_${PV}_arm.src.tar.gz \
+ file://qtopia17.patch;patch=1"
+S = "${WORKDIR}/zgscore-src"
+
+inherit palmtop
+
+EXTRA_QMAKEVARS_POST += 'TMAKE_LIBS-="-luuid" TMAKE_LIBS+="-lqpe" CONFIG+=qt CONFIG-=qtopia'
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Applications \
+ ${D}${palmtopdir}/pics
+ install -m 0755 zgscore ${D}${palmtopdir}/bin/zgscore
+ install -m 0755 zgscore.png ${D}${palmtopdir}/pics/
+ install -m 0644 zgscore.desktop ${D}${palmtopdir}/apps/Applications/
+}