aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zudoku/zudoku_1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/zudoku/zudoku_1.1.bb')
-rw-r--r--recipes/zudoku/zudoku_1.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/zudoku/zudoku_1.1.bb b/recipes/zudoku/zudoku_1.1.bb
new file mode 100644
index 0000000000..e9eb09741a
--- /dev/null
+++ b/recipes/zudoku/zudoku_1.1.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "A Sudoku Game for Opie"
+HOMEPAGE = "http://figlabs.com"
+AUTHOR = "FigLabs"
+LICENSE = "GPL"
+SECTION = "opie/games"
+APPTYPE = "binary"
+APPDESKTOP = "${WORKDIR}"
+PR = "r1"
+
+SRC_URI = "http://www.vanille.de/mirror/zudoku-${PV}.tar.gz \
+ file://zudoku.html \
+ file://zudoku.desktop"
+
+inherit opie
+
+EXTRA_QMAKEVARS_POST += "TARGET=zudoku"
+LDFLAGS += "-lstdc++"
+
+do_install() {
+ install -d ${D}${palmtopdir}/help/en/html
+ install -m 0644 ${WORKDIR}/zudoku.html ${D}${palmtopdir}/help/en/html/
+ install -d ${D}${palmtopdir}/pics/
+ install -m 0644 zudoku64x64.png ${D}${palmtopdir}/pics/zudoku.png
+}