aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/bluez/bluez4.inc4
-rw-r--r--recipes/bluez/bluez4_4.66.bb1
-rw-r--r--recipes/bluez/bluez4_4.75.bb17
3 files changed, 19 insertions, 3 deletions
diff --git a/recipes/bluez/bluez4.inc b/recipes/bluez/bluez4.inc
index a42fbbc6e9..b02ab91134 100644
--- a/recipes/bluez/bluez4.inc
+++ b/recipes/bluez/bluez4.inc
@@ -4,7 +4,7 @@ SECTION = "libs"
PRIORITY = "optional"
LICENSE = "GPLv2/LGPLv2.1"
DEPENDS = "gst-plugins-base alsa-lib virtual/libusb0 dbus-glib"
-INC_PR = "r7"
+INC_PR = "r8"
# temporary solution until bug 5176 is properly fixed
PROVIDES += "bluez-utils bluez-libs bluez-utils-dbus"
@@ -56,7 +56,7 @@ INITSCRIPT_PARAMS = "defaults 23 19"
PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"
FILES_gst-plugin-bluez = "${libdir}/gstreamer-0.10/lib*.so"
-FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so"
+FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so ${datadir}/alsa/bluetooth.conf"
FILES_${PN} += "${libdir}/bluetooth/plugins/*.so ${base_libdir}/udev"
FILES_${PN}-dev += "\
${libdir}/bluetooth/plugins/*.la \
diff --git a/recipes/bluez/bluez4_4.66.bb b/recipes/bluez/bluez4_4.66.bb
index 77e743f5bb..782e2fa61a 100644
--- a/recipes/bluez/bluez4_4.66.bb
+++ b/recipes/bluez/bluez4_4.66.bb
@@ -4,7 +4,6 @@ SRC_URI[md5sum] = "3c82575778d5dcdd68ea961626b02109"
SRC_URI[sha256sum] = "c223cbb80df0b1f17f6ef4efd0be1fe35ae640bd979f852cfbcc452abc0a7ea5"
DEFAULT_PREFERENCE = "-1"
-DEFAULT_PREFERENCE_angstrom = "1"
DEPENDS += "libnl libsndfile1"
diff --git a/recipes/bluez/bluez4_4.75.bb b/recipes/bluez/bluez4_4.75.bb
new file mode 100644
index 0000000000..20b5a6ac81
--- /dev/null
+++ b/recipes/bluez/bluez4_4.75.bb
@@ -0,0 +1,17 @@
+require bluez4.inc
+
+SRC_URI[md5sum] = "ee95086aef5955b25f1226b9e45bd6be"
+SRC_URI[sha256sum] = "fd861de5c966dc563e6a1c34400bb0c0fe1277e37655ab3ce3f48356035f61b8"
+
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_angstrom = "1"
+
+DEPENDS += "libnl libsndfile1"
+
+PR = "${INC_PR}.0"
+
+# Not all distros have a recent enough udev
+BTUDEV = " --disable-udevrules"
+BTUDEV_angstrom = " --enable-udevrules"
+BTUDEV_shr = " --enable-udevrules"
+EXTRA_OECONF += "${BTUDEV}"