aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/qscintilla/files/no-external-lexers.patch5
-rw-r--r--recipes/qscintilla/qscintilla_1.65-gpl-1.6.bb12
2 files changed, 8 insertions, 9 deletions
diff --git a/recipes/qscintilla/files/no-external-lexers.patch b/recipes/qscintilla/files/no-external-lexers.patch
index 5953043190..0214a5365b 100644
--- a/recipes/qscintilla/files/no-external-lexers.patch
+++ b/recipes/qscintilla/files/no-external-lexers.patch
@@ -1,10 +1,9 @@
-
#
# Patch managed by http://www.holgerschurig.de/patcher.html
#
---- ../src/ExternalLexer.cpp~no-external-lexers
-+++ ../src/ExternalLexer.cpp
+--- src/ExternalLexer.cpp~no-external-lexers
++++ src/ExternalLexer.cpp
@@ -110,7 +110,7 @@
// Initialise some members...
first = NULL;
diff --git a/recipes/qscintilla/qscintilla_1.65-gpl-1.6.bb b/recipes/qscintilla/qscintilla_1.65-gpl-1.6.bb
index cfed35c561..a88bf372b2 100644
--- a/recipes/qscintilla/qscintilla_1.65-gpl-1.6.bb
+++ b/recipes/qscintilla/qscintilla_1.65-gpl-1.6.bb
@@ -1,10 +1,10 @@
DESCRIPTION = "Qt/Embedded bindings for the Scintilla source code editor component"
SECTION = "opie/libs"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://www.mneuroth.de/privat/zaurus/qscintilla-${PV}_zaurus.tar.gz \
- file://no-external-lexers.patch;striplevel=0"
+ file://no-external-lexers.patch;apply=false"
S = "${WORKDIR}/qscintilla-${PV}/qt"
@@ -22,14 +22,14 @@ EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${S}/patches \
PARALLEL_MAKE = ""
-do_stage() {
- install -m 0644 qextscintilla*.h ${STAGING_INCDIR}/
- oe_libinstall -so libqscintilla ${STAGING_LIBDIR}
+do_configure_prepend() {
+ (cd .. ; patch -p0 -i ${WORKDIR}/no-external-lexers.patch)
}
do_install() {
- install -d ${D}${libdir}
+ install -d ${D}${libdir} ${D}${includedir}
oe_libinstall -so libqscintilla ${D}${libdir}
+ install -m 0644 qextscintilla*.h ${D}${includedir}/
}
FILES_${PN} = "${libdir}"