aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/networkmanager/network-manager-applet_git.bb26
1 files changed, 19 insertions, 7 deletions
diff --git a/recipes/networkmanager/network-manager-applet_git.bb b/recipes/networkmanager/network-manager-applet_git.bb
index f0bf13687a..8493f6d66c 100644
--- a/recipes/networkmanager/network-manager-applet_git.bb
+++ b/recipes/networkmanager/network-manager-applet_git.bb
@@ -2,27 +2,39 @@ DESCRIPTION = "GTK+ applet for NetworkManager"
LICENSE = "GPL"
DEPENDS = "libnotify networkmanager dbus-glib libglade gconf gnome-keyring"
RDEPENDS_${PN} = "networkmanager"
-PR = "r1"
DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_angstrom = "1"
-SRCREV = "447befc06fcfcb13322deb66bcdc9067bda0915b"
-PV = "0.7.999+git"
-PR_append = ".gitr${SRCREV}"
+SRCREV = "0.8.3.999"
+PV = "0.8.3.999"
+#PR_append = ".gitr${SRCREV}"
inherit gnome
-SRC_URI = "git://git.gnome.org/network-manager-applet;protocol=git;branch=NETWORKMANAGER_APPLET_0_7 \
-file://nm-applet.conf"
+SRC_URI = "git://git.gnome.org/network-manager-applet;protocol=git;branch=NMA_0_8 \
+ file://nm-applet.conf"
S = "${WORKDIR}/git"
+do_configure_append() {
+ rm config.log
+ # Sigh... --enable-compile-warnings=no doesn't actually turn off -Werror
+ for i in $(find ${S} -name "Makefile") ; do
+ sed -i -e s:-Werror::g $i
+ done
+}
+
# Hack around dbus a_console problems
do_install_append() {
- install -m 0644 ${WORKDIR}/nm-applet.conf ${D}${sysconfdir}/dbus-1/system.d/
+ install -m 0644 ${WORKDIR}/nm-applet.conf ${D}${sysconfdir}/dbus-1/system.d/
}
FILES_${PN} += "${datadir}/nm-applet/ \
${datadir}/gnome-vpn-properties/ \
${datadir}/gnome/autostart/ \
"
+
+FILES_${PN} += "${libdir}/gnome-bluetooth/plugins/*.so"
+FILES_${PN}-dbg += "${libdir}/gnome-bluetooth/plugins/.debug/"
+