aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/squashfs-tools/squashfs-tools.inc2
-rw-r--r--recipes/squashfs-tools/squashfs-tools_4.0.bb33
2 files changed, 7 insertions, 28 deletions
diff --git a/recipes/squashfs-tools/squashfs-tools.inc b/recipes/squashfs-tools/squashfs-tools.inc
index d06e1e52ec..aa75eaa898 100644
--- a/recipes/squashfs-tools/squashfs-tools.inc
+++ b/recipes/squashfs-tools/squashfs-tools.inc
@@ -2,7 +2,7 @@ DESCRIPTION = "Squashfs is a highly compressed read-only filesystem for Linux."
SECTION = "base"
LICENSE = "GPLv2"
DEPENDS = "zlib"
-INC_PR = "r1"
+INC_PR = "r2"
S = "${WORKDIR}/squashfs${@bb.data.getVar('PV',d,1).replace('r','-r')}/squashfs-tools"
diff --git a/recipes/squashfs-tools/squashfs-tools_4.0.bb b/recipes/squashfs-tools/squashfs-tools_4.0.bb
index 4e18489e7b..29d82a83b0 100644
--- a/recipes/squashfs-tools/squashfs-tools_4.0.bb
+++ b/recipes/squashfs-tools/squashfs-tools_4.0.bb
@@ -1,36 +1,15 @@
-DESCRIPTION = "Squashfs is a highly compressed read-only filesystem for Linux."
-SECTION = "base"
-LICENSE = "GPLv2"
-DEPENDS = "zlib"
-PR = "r2"
+require squashfs-tools.inc
+PR = "${INC_PR}.2"
-# 2009-10-22 snapshot
-#SRC_URI = "http://www.kernel.org/pub/linux/kernel/people/pkl/squashfs4.0-lzma-snapshot.tgz"
-#S = "${WORKDIR}/squashfs4.0-lzma-snapshot/squashfs-tools"
-
-SRC_URI = "cvs://anonymous@squashfs.cvs.sourceforge.net/cvsroot/squashfs;module=squashfs;date=${SRCDATE}"
+# This override is required since this has not yet been released
+SRC_URI = "cvs://anonymous@squashfs.cvs.sourceforge.net/cvsroot/squashfs;module=squashfs;date=${SRCDATE} \
+ http://downloads.sourceforge.net/sevenzip/lzma465.tar.bz2"
S = "${WORKDIR}/squashfs/squashfs-tools"
-SRC_URI += "http://downloads.sourceforge.net/sevenzip/lzma465.tar.bz2"
-
-COMP_DEFAULT = gzip
-
EXTRA_OEMAKE += "LZMA_SUPPORT=1 LZMA_DIR=../.."
-
TARGET_CC_ARCH += "${LDFLAGS}"
# the COMP_DEFAULT macro should result in a string including quotes: "gzip"
+COMP_DEFAULT = gzip
CFLAGS_append = ' -I. -I../../C -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE \
-D_GNU_SOURCE -DLZMA_SUPPORT -DCOMP_DEFAULT=\\"${COMP_DEFAULT}\\" '
-
-prefix = ""
-
-do_compile() {
- oe_runmake mksquashfs
-}
-
-do_install () {
- install -d ${D}${sbindir}
- install -m 0755 mksquashfs ${D}${sbindir}/
-}
-