aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/lzo/lzo2_2.03.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/lzo/lzo2_2.03.bb b/recipes/lzo/lzo2_2.03.bb
new file mode 100644
index 0000000000..3396b78f8a
--- /dev/null
+++ b/recipes/lzo/lzo2_2.03.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Lossless data compression library"
+HOMEPAGE = "http://www.oberhumer.com/opensource/lzo/"
+LICENSE = "GPLv2+"
+SECTION = "libs"
+PRIORITY = "optional"
+
+SRC_URI = "http://www.oberhumer.com/opensource/lzo/download/lzo-${PV}.tar.gz"
+SRC_URI[md5sum] = "0c3d078c2e8ea5a88971089a2f02a726"
+SRC_URI[sha256sum] = "8b1b0da8f757b9ac318e1c15a0eac8bdb56ca902a2dd25beda06c0f265f22591"
+
+S = "${WORKDIR}/lzo-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF = "--enable-shared"
+
+do_configure() {
+ gnu-configize --force
+ oe_runconf
+}
+
+NATIVE_INSTALL_WORKS = "1"
+BBCLASSEXTEND = "native"
+