aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/strace/strace-4.5.14/strace-dont-include-linux-dirent-h.patch23
-rw-r--r--recipes/strace/strace_4.5.14.bb3
2 files changed, 25 insertions, 1 deletions
diff --git a/recipes/strace/strace-4.5.14/strace-dont-include-linux-dirent-h.patch b/recipes/strace/strace-4.5.14/strace-dont-include-linux-dirent-h.patch
new file mode 100644
index 0000000000..1d50251417
--- /dev/null
+++ b/recipes/strace/strace-4.5.14/strace-dont-include-linux-dirent-h.patch
@@ -0,0 +1,23 @@
+Index: strace-4.5.14/file.c
+===================================================================
+--- strace-4.5.14.orig/file.c 2009-03-24 08:35:13.000000000 -0700
++++ strace-4.5.14/file.c 2009-03-24 08:39:43.000000000 -0700
+@@ -35,12 +35,12 @@
+
+ #include <dirent.h>
+ #ifdef LINUX
+-#define dirent kernel_dirent
+-#define dirent64 kernel_dirent64
+-#include <linux/types.h>
+-#include <linux/dirent.h>
+-#undef dirent
+-#undef dirent64
++struct kernel_dirent {
++ unsigned long d_ino;
++ unsigned long d_off;
++ unsigned short d_reclen;
++ char d_name[1];
++};
+ #else
+ #define kernel_dirent dirent
+ #endif
diff --git a/recipes/strace/strace_4.5.14.bb b/recipes/strace/strace_4.5.14.bb
index cb697008b8..d14891727b 100644
--- a/recipes/strace/strace_4.5.14.bb
+++ b/recipes/strace/strace_4.5.14.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "strace is a system call tracing tool."
SECTION = "console/utils"
LICENSE = "GPL"
-PR = "r7"
+PR = "r8"
SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \
file://glibc-2.5.patch;patch=1 \
@@ -12,6 +12,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \
file://strace-fix-arm-bad-syscall.patch;patch=1 \
file://strace-undef-syscall.patch;patch=1 \
file://strace-arm-no-cachectl.patch;patch=1 \
+ file://strace-dont-include-linux-dirent-h.patch;patch=1 \
"
# The strace-4.5.14-avr32.patch conflicts with some other patches.