aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rwxr-xr-xrecipes/sysvinit/sysvinit/angstrom/rc19
-rw-r--r--recipes/sysvinit/sysvinit_2.86.bb2
2 files changed, 12 insertions, 9 deletions
diff --git a/recipes/sysvinit/sysvinit/angstrom/rc b/recipes/sysvinit/sysvinit/angstrom/rc
index 6c5f4ca2ec..d1798ede39 100755
--- a/recipes/sysvinit/sysvinit/angstrom/rc
+++ b/recipes/sysvinit/sysvinit/angstrom/rc
@@ -18,18 +18,21 @@
. /etc/default/rcS
if [ -f /etc/default/splashfuncs ]; then
. /etc/default/splashfuncs
+ export SPLASH="1"
fi
export VERBOSE
startup_progress() {
- step=$(($step + $step_change))
- if [ "$num_steps" != "0" ]; then
- progress=$((($step * $progress_size / $num_steps) + $first_step))
- else
- progress=$progress_size
- fi
- #echo "PROGRESS is $progress $runlevel $first_step + ($step of $num_steps) $step_change $progress_size"
- status_position $progress || true
+ if [ "$SPLASH" = "1" ] ; then
+ step=$(($step + $step_change))
+ if [ "$num_steps" != "0" ] ; then
+ progress=$((($step * $progress_size / $num_steps) + $first_step))
+ else
+ progress=$progress_size
+ fi
+ #echo "PROGRESS is $progress $runlevel $first_step + ($step of $num_steps) $step_change $progress_size"
+ status_position $progress || true
+ fi
}
diff --git a/recipes/sysvinit/sysvinit_2.86.bb b/recipes/sysvinit/sysvinit_2.86.bb
index d3a151703f..e65391a6fd 100644
--- a/recipes/sysvinit/sysvinit_2.86.bb
+++ b/recipes/sysvinit/sysvinit_2.86.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "System-V like init."
SECTION = "base"
LICENSE = "GPL"
HOMEPAGE = "http://freshmeat.net/projects/sysvinit/"
-PR = "r52"
+PR = "r53"
# USE_VT and SERIAL_CONSOLE are generally defined by the MACHINE .conf.
# Set PACKAGE_ARCH appropriately.