aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/apache2/apache2_2.2.14.bb4
-rw-r--r--recipes/apr/apr-util_1.3.4.bb2
-rw-r--r--recipes/apr/apr_1.3.12.bb2
-rw-r--r--recipes/apr/apr_1.3.3.bb2
-rw-r--r--recipes/apr/apr_1.3.5.bb2
-rw-r--r--recipes/ayatana/indicator-network_0.2.6.bb2
-rw-r--r--recipes/cpufreqd/cpufrequtils_006.bb2
-rw-r--r--recipes/gnome/gnome-bluetooth_2.30.0.bb2
-rw-r--r--recipes/gnome/system-tools-backends_2.10.1.bb2
-rw-r--r--recipes/gtk-webcore/osb-jscore_0.5.0.bb4
-rw-r--r--recipes/gtk-webcore/osb-jscore_20050430.bb4
-rw-r--r--recipes/gtk-webcore/osb-jscore_20070816.bb4
-rw-r--r--recipes/gtk-webcore/osb-jscore_svn.bb4
-rw-r--r--recipes/gtk-webcore/osb-nrcit_0.5.0.bb4
-rw-r--r--recipes/gtk-webcore/osb-nrcit_20050430.bb4
-rw-r--r--recipes/gtk-webcore/osb-nrcit_20070816.bb4
-rw-r--r--recipes/gtk-webcore/osb-nrcit_svn.bb4
-rw-r--r--recipes/gtk-webcore/osb-nrcore.inc4
-rw-r--r--recipes/libsdl/libsdl-native.inc4
-rw-r--r--recipes/libsdl/libsdl.inc4
-rw-r--r--recipes/libtool/libtool-2.2.6a/prefix.patch2
-rw-r--r--recipes/libtool/libtool-2.2.6b/prefix.patch2
-rw-r--r--recipes/libtool/libtool-2.4/prefix.patch2
-rw-r--r--recipes/obsolete/gpephone/linphone_1.5.0.bb8
-rw-r--r--recipes/sane/sane-backends_1.0.19.bb2
-rw-r--r--recipes/sane/sane-backends_1.0.20.bb2
-rw-r--r--recipes/webkit/webkit-gtk_1.2.3.bb2
-rw-r--r--recipes/webkit/webkit-gtk_svn.bb2
28 files changed, 43 insertions, 43 deletions
diff --git a/recipes/apache2/apache2_2.2.14.bb b/recipes/apache2/apache2_2.2.14.bb
index a78c373c01..8a6b38d09f 100644
--- a/recipes/apache2/apache2_2.2.14.bb
+++ b/recipes/apache2/apache2_2.2.14.bb
@@ -91,7 +91,7 @@ EXTRA_OECONF = "--enable-ssl \
#
do_configure_prepend() {
- sed -e 's,libtool libtool15,${TARGET_PREFIX}libtool libtool115,' -i ${S}/srclib/apr/build/buildcheck.sh
+ sed -e 's,libtool libtool15,${HOST_SYS}-libtool libtool115,' -i ${S}/srclib/apr/build/buildcheck.sh
}
do_configure() {
@@ -100,7 +100,7 @@ do_configure() {
}
do_compile_prepend() {
- ln -sf ${S}/srclib/apr/${TARGET_PREFIX}libtool ${S}/srclib/apr/libtool
+ ln -sf ${S}/srclib/apr/${HOST_SYS}-libtool ${S}/srclib/apr/libtool
}
do_install_append() {
diff --git a/recipes/apr/apr-util_1.3.4.bb b/recipes/apr/apr-util_1.3.4.bb
index 3a2284c4d0..a2c8211fd0 100644
--- a/recipes/apr/apr-util_1.3.4.bb
+++ b/recipes/apr/apr-util_1.3.4.bb
@@ -30,7 +30,7 @@ do_configure_prepend() {
do_configure_append() {
sed -i -e s:apr_builders=/usr/share/build-1:apr_builders=${STAGING_DATADIR}/build-1:g ${S}/build/rules.mk
sed -i /^LIBTOOL/d ${S}/build/rules.mk
- echo LIBTOOL="${TARGET_PREFIX}libtool --tag=CC" >> ${S}/build/rules.mk
+ echo LIBTOOL="${HOST_SYS}-libtool --tag=CC" >> ${S}/build/rules.mk
}
diff --git a/recipes/apr/apr_1.3.12.bb b/recipes/apr/apr_1.3.12.bb
index 60624c9e5b..38ed343ce4 100644
--- a/recipes/apr/apr_1.3.12.bb
+++ b/recipes/apr/apr_1.3.12.bb
@@ -28,7 +28,7 @@ do_install_append() {
cp ${S}/build/apr_rules.mk ${D}${datadir}/apr/
sed -i s,apr_builddir=.*,apr_builddir=,g ${D}${datadir}/apr/apr_rules.mk
sed -i s,apr_builders=.*,apr_builders=,g ${D}${datadir}/apr/apr_rules.mk
- sed -i s,LIBTOOL=.*,LIBTOOL=\$\(SHELL\)\ ${TARGET_PREFIX}libtool,g ${D}${datadir}/apr/apr_rules.mk
+ sed -i s,LIBTOOL=.*,LIBTOOL=\$\(SHELL\)\ ${HOST_SYS}-libtool,g ${D}${datadir}/apr/apr_rules.mk
sed -i s,\$\(apr_builders\),${D}${datadir}/apr/,g ${D}${datadir}/apr/apr_rules.mk
cp ${S}/build/mkdir.sh ${D}${datadir}/apr/
cp ${S}/build/make_exports.awk ${D}${datadir}/apr/
diff --git a/recipes/apr/apr_1.3.3.bb b/recipes/apr/apr_1.3.3.bb
index 3a49235842..22e399d271 100644
--- a/recipes/apr/apr_1.3.3.bb
+++ b/recipes/apr/apr_1.3.3.bb
@@ -24,7 +24,7 @@ do_stage() {
cp ${S}/build/apr_rules.mk ${STAGING_DATADIR}/apr/
sed -i s,apr_builddir=.*,apr_builddir=,g ${STAGING_DATADIR}/apr/apr_rules.mk
sed -i s,apr_builders=.*,apr_builders=,g ${STAGING_DATADIR}/apr/apr_rules.mk
- sed -i s,LIBTOOL=.*,LIBTOOL=\$\(SHELL\)\ ${TARGET_PREFIX}libtool,g ${STAGING_DATADIR}/apr/apr_rules.mk
+ sed -i s,LIBTOOL=.*,LIBTOOL=\$\(SHELL\)\ ${HOST_SYS}-libtool,g ${STAGING_DATADIR}/apr/apr_rules.mk
sed -i s,\$\(apr_builders\),${STAGING_DATADIR}/apr/,g ${STAGING_DATADIR}/apr/apr_rules.mk
cp ${S}/build/mkdir.sh ${STAGING_DATADIR}/apr/
cp ${S}/build/make_exports.awk ${STAGING_DATADIR}/apr/
diff --git a/recipes/apr/apr_1.3.5.bb b/recipes/apr/apr_1.3.5.bb
index 955334f279..4f4c288175 100644
--- a/recipes/apr/apr_1.3.5.bb
+++ b/recipes/apr/apr_1.3.5.bb
@@ -24,7 +24,7 @@ do_stage() {
cp ${S}/build/apr_rules.mk ${STAGING_DATADIR}/apr/
sed -i s,apr_builddir=.*,apr_builddir=,g ${STAGING_DATADIR}/apr/apr_rules.mk
sed -i s,apr_builders=.*,apr_builders=,g ${STAGING_DATADIR}/apr/apr_rules.mk
- sed -i s,LIBTOOL=.*,LIBTOOL=\$\(SHELL\)\ ${TARGET_PREFIX}libtool,g ${STAGING_DATADIR}/apr/apr_rules.mk
+ sed -i s,LIBTOOL=.*,LIBTOOL=\$\(SHELL\)\ ${HOST_SYS}-libtool,g ${STAGING_DATADIR}/apr/apr_rules.mk
sed -i s,\$\(apr_builders\),${STAGING_DATADIR}/apr/,g ${STAGING_DATADIR}/apr/apr_rules.mk
cp ${S}/build/mkdir.sh ${STAGING_DATADIR}/apr/
cp ${S}/build/make_exports.awk ${STAGING_DATADIR}/apr/
diff --git a/recipes/ayatana/indicator-network_0.2.6.bb b/recipes/ayatana/indicator-network_0.2.6.bb
index f5a25ebb78..7630467e18 100644
--- a/recipes/ayatana/indicator-network_0.2.6.bb
+++ b/recipes/ayatana/indicator-network_0.2.6.bb
@@ -10,7 +10,7 @@ SRC_URI = "http://launchpad.net/indicator-network/trunk/0.2.6/+download/indicato
# Fixed for wrong test in libtool without it I get this bogus error:
# arm-angstrom-linux-gnueabi-libtool: install: error: cannot install `libnetworkmenu.la' to a directory not ending in /usr/lib/indicators/3/
do_configure_append() {
- sed -i 's,func_fatal_error "error: cannot install,echo "bogus message about,' ${TARGET_PREFIX}libtool
+ sed -i 's,func_fatal_error "error: cannot install,echo "bogus message about,' ${HOST_SYS}-libtool
}
FILES_${PN} += "${libdir}/indicators/3/* /usr/share/dbus-1/services/*"
diff --git a/recipes/cpufreqd/cpufrequtils_006.bb b/recipes/cpufreqd/cpufrequtils_006.bb
index 4574e396dc..869376d5ea 100644
--- a/recipes/cpufreqd/cpufrequtils_006.bb
+++ b/recipes/cpufreqd/cpufrequtils_006.bb
@@ -8,7 +8,7 @@ SRC_URI = "http://www.kernel.org/pub/linux/utils/kernel/cpufreq/cpufrequtils-${P
"
export CROSS = "${TARGET_PREFIX}"
-export LIBTOOL = "${TARGET_PREFIX}libtool --tag cc"
+export LIBTOOL = "${HOST_SYS}-libtool --tag cc"
TARGET_CC_ARCH += "${LDFLAGS}"
diff --git a/recipes/gnome/gnome-bluetooth_2.30.0.bb b/recipes/gnome/gnome-bluetooth_2.30.0.bb
index 535735a3a6..238d039fb3 100644
--- a/recipes/gnome/gnome-bluetooth_2.30.0.bb
+++ b/recipes/gnome/gnome-bluetooth_2.30.0.bb
@@ -19,7 +19,7 @@ do_configure_prepend() {
}
do_configure_append() {
- sed -i 's,func_fatal_error "error: cannot install,echo "bogus message about,' ${TARGET_PREFIX}libtool
+ sed -i 's,func_fatal_error "error: cannot install,echo "bogus message about,' ${HOST_SYS}-libtool
}
RRECOMMENDS_${PN} += "obexd obex-data-server"
diff --git a/recipes/gnome/system-tools-backends_2.10.1.bb b/recipes/gnome/system-tools-backends_2.10.1.bb
index bac0a9cb16..225c5daeba 100644
--- a/recipes/gnome/system-tools-backends_2.10.1.bb
+++ b/recipes/gnome/system-tools-backends_2.10.1.bb
@@ -32,7 +32,7 @@ do_configure() {
aclocal
gnu-configize
oe_runconf
- cp ${STAGING_BINDIR_CROSS}/${TARGET_PREFIX}libtool ${S}
+ cp ${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool ${S}
}
do_install_append () {
diff --git a/recipes/gtk-webcore/osb-jscore_0.5.0.bb b/recipes/gtk-webcore/osb-jscore_0.5.0.bb
index 924b40f741..37a4fd353a 100644
--- a/recipes/gtk-webcore/osb-jscore_0.5.0.bb
+++ b/recipes/gtk-webcore/osb-jscore_0.5.0.bb
@@ -20,8 +20,8 @@ do_configure () {
cd ${S}
# prevent libtool from linking libs against libstdc++, libgcc, ...
- cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
- mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
+ cat ${HOST_SYS}-libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${HOST_SYS}-libtool.tmp
+ mv ${HOST_SYS}-libtool.tmp ${HOST_SYS}-libtool
}
do_stage () {
diff --git a/recipes/gtk-webcore/osb-jscore_20050430.bb b/recipes/gtk-webcore/osb-jscore_20050430.bb
index bffeae4e14..d3770227c3 100644
--- a/recipes/gtk-webcore/osb-jscore_20050430.bb
+++ b/recipes/gtk-webcore/osb-jscore_20050430.bb
@@ -22,8 +22,8 @@ do_configure () {
cd ${S}
# prevent libtool from linking libs against libstdc++, libgcc, ...
- cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
- mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
+ cat ${HOST_SYS}-libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${HOST_SYS}-libtool.tmp
+ mv ${HOST_SYS}-libtool.tmp ${HOST_SYS}-libtool
}
do_stage () {
diff --git a/recipes/gtk-webcore/osb-jscore_20070816.bb b/recipes/gtk-webcore/osb-jscore_20070816.bb
index 276d055404..f5ee1b2e26 100644
--- a/recipes/gtk-webcore/osb-jscore_20070816.bb
+++ b/recipes/gtk-webcore/osb-jscore_20070816.bb
@@ -24,8 +24,8 @@ do_configure () {
cd ${S}
# prevent libtool from linking libs against libstdc++, libgcc, ...
- cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
- mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
+ cat ${HOST_SYS}-libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${HOST_SYS}-libtool.tmp
+ mv ${HOST_SYS}-libtool.tmp ${HOST_SYS}-libtool
}
do_stage () {
diff --git a/recipes/gtk-webcore/osb-jscore_svn.bb b/recipes/gtk-webcore/osb-jscore_svn.bb
index afa65bf534..fa22542f9b 100644
--- a/recipes/gtk-webcore/osb-jscore_svn.bb
+++ b/recipes/gtk-webcore/osb-jscore_svn.bb
@@ -24,8 +24,8 @@ do_configure () {
cd ${S}
# prevent libtool from linking libs against libstdc++, libgcc, ...
- cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
- mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
+ cat ${HOST_SYS}-libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${HOST_SYS}-libtool.tmp
+ mv ${HOST_SYS}-libtool.tmp ${HOST_SYS}-libtool
}
do_stage () {
diff --git a/recipes/gtk-webcore/osb-nrcit_0.5.0.bb b/recipes/gtk-webcore/osb-nrcit_0.5.0.bb
index fe38469d49..f6b3f69da3 100644
--- a/recipes/gtk-webcore/osb-nrcit_0.5.0.bb
+++ b/recipes/gtk-webcore/osb-nrcit_0.5.0.bb
@@ -15,8 +15,8 @@ do_configure () {
cd ${S}
# prevent libtool from linking libs against libstdc++, libgcc, ...
- cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
- mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
+ cat ${HOST_SYS}-libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${HOST_SYS}-libtool.tmp
+ mv ${HOST_SYS}-libtool.tmp ${HOST_SYS}-libtool
}
do_stage () {
diff --git a/recipes/gtk-webcore/osb-nrcit_20050430.bb b/recipes/gtk-webcore/osb-nrcit_20050430.bb
index 085313adb8..d2100a7fd6 100644
--- a/recipes/gtk-webcore/osb-nrcit_20050430.bb
+++ b/recipes/gtk-webcore/osb-nrcit_20050430.bb
@@ -24,8 +24,8 @@ do_configure () {
cd ${S}
# prevent libtool from linking libs against libstdc++, libgcc, ...
- cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
- mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
+ cat ${HOST_SYS}-libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${HOST_SYS}-libtool.tmp
+ mv ${HOST_SYS}-libtool.tmp ${HOST_SYS}-libtool
}
do_stage () {
diff --git a/recipes/gtk-webcore/osb-nrcit_20070816.bb b/recipes/gtk-webcore/osb-nrcit_20070816.bb
index e1b4695103..317c052ae7 100644
--- a/recipes/gtk-webcore/osb-nrcit_20070816.bb
+++ b/recipes/gtk-webcore/osb-nrcit_20070816.bb
@@ -24,8 +24,8 @@ do_configure () {
cd ${S}
# prevent libtool from linking libs against libstdc++, libgcc, ...
- cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
- mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
+ cat ${HOST_SYS}-libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${HOST_SYS}-libtool.tmp
+ mv ${HOST_SYS}-libtool.tmp ${HOST_SYS}-libtool
}
do_stage () {
diff --git a/recipes/gtk-webcore/osb-nrcit_svn.bb b/recipes/gtk-webcore/osb-nrcit_svn.bb
index 00aebce0cb..c46de2ffe6 100644
--- a/recipes/gtk-webcore/osb-nrcit_svn.bb
+++ b/recipes/gtk-webcore/osb-nrcit_svn.bb
@@ -25,8 +25,8 @@ do_configure () {
cd ${S}
# prevent libtool from linking libs against libstdc++, libgcc, ...
- cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
- mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
+ cat ${HOST_SYS}-libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${HOST_SYS}-libtool.tmp
+ mv ${HOST_SYS}-libtool.tmp ${HOST_SYS}-libtool
}
do_stage () {
diff --git a/recipes/gtk-webcore/osb-nrcore.inc b/recipes/gtk-webcore/osb-nrcore.inc
index eca304959f..5575571fde 100644
--- a/recipes/gtk-webcore/osb-nrcore.inc
+++ b/recipes/gtk-webcore/osb-nrcore.inc
@@ -19,8 +19,8 @@ do_configure () {
cd ${S}
# prevent libtool from linking libs against libstdc++, libgcc, ...
- cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
- mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
+ cat ${HOST_SYS}-libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${HOST_SYS}-libtool.tmp
+ mv ${HOST_SYS}-libtool.tmp ${HOST_SYS}-libtool
}
do_install_append() {
diff --git a/recipes/libsdl/libsdl-native.inc b/recipes/libsdl/libsdl-native.inc
index faae90c729..d007fdadfc 100644
--- a/recipes/libsdl/libsdl-native.inc
+++ b/recipes/libsdl/libsdl-native.inc
@@ -27,7 +27,7 @@ do_configure() {
oe_runconf
cd ${S}
# prevent libtool from linking libs against libstdc++, libgcc, ...
- cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
- mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
+ cat ${HOST_SYS}-libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${HOST_SYS}-libtool.tmp
+ mv ${HOST_SYS}-libtool.tmp ${HOST_SYS}-libtool
}
diff --git a/recipes/libsdl/libsdl.inc b/recipes/libsdl/libsdl.inc
index 9f748e1953..01da500b53 100644
--- a/recipes/libsdl/libsdl.inc
+++ b/recipes/libsdl/libsdl.inc
@@ -32,8 +32,8 @@ do_configure_append () {
cd ${S}
# prevent libtool from linking libs against libstdc++, libgcc, ...
- cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
- mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
+ cat ${HOST_SYS}-libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${HOST_SYS}-libtool.tmp
+ mv ${HOST_SYS}-libtool.tmp ${HOST_SYS}-libtool
}
do_stage() {
diff --git a/recipes/libtool/libtool-2.2.6a/prefix.patch b/recipes/libtool/libtool-2.2.6a/prefix.patch
index 639feb7456..38d58ed61e 100644
--- a/recipes/libtool/libtool-2.2.6a/prefix.patch
+++ b/recipes/libtool/libtool-2.2.6a/prefix.patch
@@ -1,4 +1,4 @@
-Renames "libtool" -> "${TARGET_PREFIX}libtool" which makes sure
+Renames "libtool" -> "${HOST_SYS}-libtool" which makes sure
it can't be confused with the host libtool.
Index: libtool-2.2.2/libltdl/m4/libtool.m4
diff --git a/recipes/libtool/libtool-2.2.6b/prefix.patch b/recipes/libtool/libtool-2.2.6b/prefix.patch
index 639feb7456..38d58ed61e 100644
--- a/recipes/libtool/libtool-2.2.6b/prefix.patch
+++ b/recipes/libtool/libtool-2.2.6b/prefix.patch
@@ -1,4 +1,4 @@
-Renames "libtool" -> "${TARGET_PREFIX}libtool" which makes sure
+Renames "libtool" -> "${HOST_SYS}-libtool" which makes sure
it can't be confused with the host libtool.
Index: libtool-2.2.2/libltdl/m4/libtool.m4
diff --git a/recipes/libtool/libtool-2.4/prefix.patch b/recipes/libtool/libtool-2.4/prefix.patch
index 70bbd15461..853bc421da 100644
--- a/recipes/libtool/libtool-2.4/prefix.patch
+++ b/recipes/libtool/libtool-2.4/prefix.patch
@@ -1,4 +1,4 @@
-Renames "libtool" -> "${TARGET_PREFIX}libtool" which makes sure
+Renames "libtool" -> "${HOST_SYS}-libtool" which makes sure
it can't be confused with the host libtool.
Originally by: RP
diff --git a/recipes/obsolete/gpephone/linphone_1.5.0.bb b/recipes/obsolete/gpephone/linphone_1.5.0.bb
index 0d20693fad..e771185e2a 100644
--- a/recipes/obsolete/gpephone/linphone_1.5.0.bb
+++ b/recipes/obsolete/gpephone/linphone_1.5.0.bb
@@ -21,16 +21,16 @@ EXTRA_OECONF = "--disable-gnome_ui --disable-gtk-doc --without-ffmpeg \
--disable-glibtest --disable-glib --disable-strict"
do_configure () {
- export LIBTOOL="${STAGING_BINDIR_NATIVE}/${TARGET_PREFIX}libtool"
+ export LIBTOOL="${STAGING_BINDIR_NATIVE}/${HOST_SYS}-libtool"
oe_runconf SPEEX_LIBS="-lspeex" SPEEX_CFLAGS=" "
}
do_compile () {
- oe_runmake LIBTOOL="${STAGING_BINDIR_NATIVE}/${TARGET_PREFIX}libtool" SPEEX_LIBS="-lspeex" SPEEX_CFLAGS=" "
+ oe_runmake LIBTOOL="${STAGING_BINDIR_NATIVE}/${HOST_SYS}-libtool" SPEEX_LIBS="-lspeex" SPEEX_CFLAGS=" "
}
do_install () {
- oe_runmake install "DESTDIR=${D}" "LIBTOOL=${STAGING_BINDIR_NATIVE}/${TARGET_PREFIX}libtool"
+ oe_runmake install "DESTDIR=${D}" "LIBTOOL=${STAGING_BINDIR_NATIVE}/${HOST_SYS}-libtool"
}
do_install_append() {
@@ -39,7 +39,7 @@ do_install_append() {
}
do_stage() {
- export LIBTOOL="${STAGING_BINDIR_NATIVE}/${TARGET_PREFIX}libtool"
+ export LIBTOOL="${STAGING_BINDIR_NATIVE}/${HOST_SYS}-libtool"
autotools_stage_all
rm ${STAGING_LIBDIR}/libquickstream.la
rm ${STAGING_LIBDIR}/libmediastreamer.la
diff --git a/recipes/sane/sane-backends_1.0.19.bb b/recipes/sane/sane-backends_1.0.19.bb
index 56ffd89f42..9faf7c2217 100644
--- a/recipes/sane/sane-backends_1.0.19.bb
+++ b/recipes/sane/sane-backends_1.0.19.bb
@@ -22,7 +22,7 @@ do_configure_prepend() {
PARALLEL_MAKE = ""
do_compile_prepend() {
- ln -sf ${S}/${TARGET_PREFIX}libtool ${S}/libtool
+ ln -sf ${S}/${HOST_SYS}-libtool ${S}/libtool
}
do_install_append() {
diff --git a/recipes/sane/sane-backends_1.0.20.bb b/recipes/sane/sane-backends_1.0.20.bb
index ce1db1e1d7..a8ea046f10 100644
--- a/recipes/sane/sane-backends_1.0.20.bb
+++ b/recipes/sane/sane-backends_1.0.20.bb
@@ -21,7 +21,7 @@ do_configure_prepend() {
PARALLEL_MAKE = ""
do_compile_prepend() {
- ln -sf ${S}/${TARGET_PREFIX}libtool ${S}/libtool
+ ln -sf ${S}/${HOST_SYS}-libtool ${S}/libtool
}
do_install_append() {
diff --git a/recipes/webkit/webkit-gtk_1.2.3.bb b/recipes/webkit/webkit-gtk_1.2.3.bb
index e223a649ba..90d880cc81 100644
--- a/recipes/webkit/webkit-gtk_1.2.3.bb
+++ b/recipes/webkit/webkit-gtk_1.2.3.bb
@@ -24,7 +24,7 @@ EXTRA_AUTORECONF = " -I autotools "
# Dolt gets used on x86 and ppc and hardcodes 'libtool'
do_configure_append() {
- cp ${TARGET_PREFIX}libtool libtool || true
+ cp ${HOST_SYS}-libtool libtool || true
}
do_compile_prepend() {
diff --git a/recipes/webkit/webkit-gtk_svn.bb b/recipes/webkit/webkit-gtk_svn.bb
index 4a12c34795..55bf643d17 100644
--- a/recipes/webkit/webkit-gtk_svn.bb
+++ b/recipes/webkit/webkit-gtk_svn.bb
@@ -42,7 +42,7 @@ EXTRA_AUTORECONF = " -I autotools "
# Dolt gets used on x86 and ppc and hardcodes 'libtool'
do_configure_append() {
- cp ${TARGET_PREFIX}libtool libtool || true
+ cp ${HOST_SYS}-libtool libtool || true
}
do_compile_prepend() {