aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/qt4/qt4-x11-free.inc1
-rw-r--r--recipes/qt4/qt4-x11-free_4.1.2.bb4
-rw-r--r--recipes/qt4/qt4-x11-free_4.3.3.bb2
-rw-r--r--recipes/qt4/qt4-x11-free_4.4.3.bb2
-rw-r--r--recipes/qt4/qt_depends.inc2
-rw-r--r--recipes/qt4/qt_staging.inc10
6 files changed, 10 insertions, 11 deletions
diff --git a/recipes/qt4/qt4-x11-free.inc b/recipes/qt4/qt4-x11-free.inc
index 93e11755c4..6f490425f0 100644
--- a/recipes/qt4/qt4-x11-free.inc
+++ b/recipes/qt4/qt4-x11-free.inc
@@ -5,7 +5,6 @@ HOMEPAGE = "http://www.trolltech.com"
LICENSE = "GPL QPL"
DEPENDS += "virtual/libx11 fontconfig xft libxext libxrender libxrandr libxcursor"
PROVIDES = "qt4x11"
-PR = "r11"
SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-x11-opensource-src-${PV}.tar.gz \
file://0001-cross-compile.patch;patch=1 \
diff --git a/recipes/qt4/qt4-x11-free_4.1.2.bb b/recipes/qt4/qt4-x11-free_4.1.2.bb
index 54c706463a..1b762809c9 100644
--- a/recipes/qt4/qt4-x11-free_4.1.2.bb
+++ b/recipes/qt4/qt4-x11-free_4.1.2.bb
@@ -2,9 +2,9 @@ SECTION = "x11/libs"
PRIORITY = "optional"
HOMEPAGE = "http://www.trolltech.com"
LICENSE = "GPL QPL"
-DEPENDS = "uicmoc4-native qmake2-native freetype jpeg virtual/libx11 xft libxext libxrender libxrandr libxcursor"
+DEPENDS = "qt4-tools-native freetype jpeg virtual/libx11 xft libxext libxrender libxrandr libxcursor"
PROVIDES = "qt4x11"
-PR = "r1"
+PR = "r2"
SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-x11-opensource-src-${PV}.tar.gz \
file://cross-compile.patch;patch=1 \
diff --git a/recipes/qt4/qt4-x11-free_4.3.3.bb b/recipes/qt4/qt4-x11-free_4.3.3.bb
index 7d30503c07..766b26dd63 100644
--- a/recipes/qt4/qt4-x11-free_4.3.3.bb
+++ b/recipes/qt4/qt4-x11-free_4.3.3.bb
@@ -1,4 +1,6 @@
require qt4-x11-free.inc
+PR = "r12"
+
SRC_URI += " \
file://0002-fix-resinit-declaration.patch;patch=1 \
file://0006-freetype-host-includes.patch;patch=1 \
diff --git a/recipes/qt4/qt4-x11-free_4.4.3.bb b/recipes/qt4/qt4-x11-free_4.4.3.bb
index d1bf335420..c6756942d5 100644
--- a/recipes/qt4/qt4-x11-free_4.4.3.bb
+++ b/recipes/qt4/qt4-x11-free_4.4.3.bb
@@ -1,5 +1,5 @@
require qt4-x11-free.inc
-PR = "r5"
+PR = "r6"
SRC_URI += " \
file://0002-fix-resinit-declaration.patch;patch=1 \
diff --git a/recipes/qt4/qt_depends.inc b/recipes/qt4/qt_depends.inc
index 26cffa224f..bdb5fafd6e 100644
--- a/recipes/qt4/qt_depends.inc
+++ b/recipes/qt4/qt_depends.inc
@@ -1,3 +1,3 @@
inherit pkgconfig qmake_base
-DEPENDS += " uicmoc4-native qmake2-native freetype jpeg libpng zlib dbus openssl glib-2.0 gstreamer gst-plugins-base"
+DEPENDS += " qt4-tools-native freetype jpeg libpng zlib dbus openssl glib-2.0 gstreamer gst-plugins-base"
diff --git a/recipes/qt4/qt_staging.inc b/recipes/qt4/qt_staging.inc
index 21e1b4c31f..c7b1e66669 100644
--- a/recipes/qt4/qt_staging.inc
+++ b/recipes/qt4/qt_staging.inc
@@ -16,12 +16,10 @@ do_stage_append() {
sed -i s#"-L${S}/lib"##g libQt*.la
sed -i s#'$(OE_QMAKE_LIBS_X11)'#"${OE_QMAKE_LIBS_X11}"#g libQt*.la
- # FIXME: is this really needed?
- install -d ${STAGING_DIR_TARGET}/qt4/bin
- cp ${STAGING_DIR_NATIVE}/qt4/bin/* ${STAGING_DIR_TARGET}/qt4/bin/ || true
- cp ${STAGING_DIR_NATIVE}/${bindir}/{rcc*,uic*,moc*} ${STAGING_DIR_TARGET}/qt4/bin/ || true
- for qttool in ${STAGING_DIR_TARGET}/qt4/bin/*4 ; do
- ln -sf $qttool ${STAGING_DIR_TARGET}/qt4/bin/$(basename $qttool |sed s:4::g)
+ install -d ${STAGING_DATADIR}/${QT_DIR_NAME}/bin
+ ln -sf ${STAGING_BINDIR_NATIVE}/qmake2 ${STAGING_DATADIR}/${QT_DIR_NAME}/bin/qmake
+ for qttool in qmake moc uic uic3 rcc lrelease lupdate; do
+ ln -sf ${STAGING_BINDIR_NATIVE}/${qttool}4 ${STAGING_DATADIR}/${QT_DIR_NAME}/bin/${qttool}
done
}