aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/guile/files/cpp-fix.patch14
-rw-r--r--recipes/xorg-proto/xproto-native_7.0.15.bb2
2 files changed, 8 insertions, 8 deletions
diff --git a/recipes/guile/files/cpp-fix.patch b/recipes/guile/files/cpp-fix.patch
index 4a6bea018d..615cf4c2a6 100644
--- a/recipes/guile/files/cpp-fix.patch
+++ b/recipes/guile/files/cpp-fix.patch
@@ -1,10 +1,8 @@
---- ./libguile/guile-snarf-docs.in-orig 2013-02-20 22:31:43.000000000 +0100
-+++ ./libguile/guile-snarf-docs.in 2013-02-20 22:32:08.000000000 +0100
-@@ -21,6 +21,6 @@
- bindir=`dirname $0`
-
+--- ./libguile/guile-snarf-docs.in-orig 2013-02-20 22:57:55.000000000 +0100
++++ ./libguile/guile-snarf-docs.in 2013-02-20 22:58:17.000000000 +0100
+@@ -23,4 +23,4 @@
## Let the user override the preprocessor autoconf found.
--test -n "${CPP+set}" || CPP="@CPP@"
-+test -n "${CPP+set}" || CPP="cpp -E -P"
+ test -n "${CPP+set}" || CPP="@CPP@"
- ${CPP} -DSCM_MAGIC_SNARF_DOCS "$@"
+-${CPP} -DSCM_MAGIC_SNARF_DOCS "$@"
++${CPP} -P -DSCM_MAGIC_SNARF_DOCS "$@"
diff --git a/recipes/xorg-proto/xproto-native_7.0.15.bb b/recipes/xorg-proto/xproto-native_7.0.15.bb
index 5dde8a7d4a..baecb29fc8 100644
--- a/recipes/xorg-proto/xproto-native_7.0.15.bb
+++ b/recipes/xorg-proto/xproto-native_7.0.15.bb
@@ -1,3 +1,5 @@
require xproto_${PV}.bb
inherit native
+
+DEPENDS += "util-macros-native"