aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/busybox/busybox-1.11.3/udhcpc-background.patch21
-rw-r--r--recipes/busybox/busybox-1.13.2/udhcpc-background.patch21
-rw-r--r--recipes/busybox/busybox_1.11.3.bb1
-rw-r--r--recipes/busybox/busybox_1.13.2.bb1
4 files changed, 44 insertions, 0 deletions
diff --git a/recipes/busybox/busybox-1.11.3/udhcpc-background.patch b/recipes/busybox/busybox-1.11.3/udhcpc-background.patch
new file mode 100644
index 0000000000..072ce88327
--- /dev/null
+++ b/recipes/busybox/busybox-1.11.3/udhcpc-background.patch
@@ -0,0 +1,21 @@
+diff -Nurd busybox-1.11.3.orig//networking/ifupdown.c busybox-1.11.3/networking/ifupdown.c
+--- busybox-1.11.3.orig//networking/ifupdown.c 2010-06-15 08:45:44.000000000 +0200
++++ busybox-1.11.3/networking/ifupdown.c 2010-06-15 08:46:09.000000000 +0200
+@@ -476,7 +476,7 @@
+ "pump -i %iface% -k",
+ },
+ { "udhcpc",
+- "udhcpc -R -n -p /var/run/udhcpc.%iface%.pid -i %iface%[[ -H %hostname%]][[ -c %clientid%]]"
++ "udhcpc -R -b -p /var/run/udhcpc.%iface%.pid -i %iface%[[ -H %hostname%]][[ -c %clientid%]]"
+ "[[ -s %script%]][[ %udhcpc_opts%]]",
+ "kill `cat /var/run/udhcpc.%iface%.pid` 2>/dev/null",
+ },
+@@ -507,7 +507,7 @@
+ if (!execute("ip link set %iface% up", ifd, exec))
+ return 0;
+ #endif
+- return execute("udhcpc -R -n -p /var/run/udhcpc.%iface%.pid "
++ return execute("udhcpc -R -b -p /var/run/udhcpc.%iface%.pid "
+ "-i %iface%[[ -H %hostname%]][[ -c %clientid%]][[ -s %script%]][[ %udhcpc_opts%]]",
+ ifd, exec);
+ }
diff --git a/recipes/busybox/busybox-1.13.2/udhcpc-background.patch b/recipes/busybox/busybox-1.13.2/udhcpc-background.patch
new file mode 100644
index 0000000000..792023da75
--- /dev/null
+++ b/recipes/busybox/busybox-1.13.2/udhcpc-background.patch
@@ -0,0 +1,21 @@
+diff -Nurd busybox-1.13.2.orig//networking/ifupdown.c busybox-1.13.2/networking/ifupdown.c
+--- busybox-1.13.2.orig//networking/ifupdown.c 2010-06-15 08:37:32.000000000 +0200
++++ busybox-1.13.2/networking/ifupdown.c 2010-06-15 08:38:05.000000000 +0200
+@@ -487,7 +487,7 @@
+ "pump -i %iface% -k",
+ },
+ { "udhcpc",
+- "udhcpc -R -n -p /var/run/udhcpc.%iface%.pid -i %iface%[[ -H %hostname%]][[ -c %clientid%]]"
++ "udhcpc -R -b -p /var/run/udhcpc.%iface%.pid -i %iface%[[ -H %hostname%]][[ -c %clientid%]]"
+ "[[ -s %script%]][[ %udhcpc_opts%]]",
+ "kill `cat /var/run/udhcpc.%iface%.pid` 2>/dev/null",
+ },
+@@ -526,7 +526,7 @@
+ if (!execute("ifconfig %iface%[[ hw %hwaddress%]] up", ifd, exec))
+ return 0;
+ #endif
+- return execute("udhcpc -R -n -p /var/run/udhcpc.%iface%.pid "
++ return execute("udhcpc -R -b -p /var/run/udhcpc.%iface%.pid "
+ "-i %iface%[[ -H %hostname%]][[ -c %clientid%]][[ -s %script%]][[ %udhcpc_opts%]]",
+ ifd, exec);
+ }
diff --git a/recipes/busybox/busybox_1.11.3.bb b/recipes/busybox/busybox_1.11.3.bb
index fa169efd9c..7ddfd9ecb2 100644
--- a/recipes/busybox/busybox_1.11.3.bb
+++ b/recipes/busybox/busybox_1.11.3.bb
@@ -5,6 +5,7 @@ SRC_URI = "\
http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
\
file://udhcpscript.patch \
+ file://udhcpc-background.patch \
file://B921600.patch \
file://fdisk_lineedit_segfault.patch \
file://iptunnel.patch \
diff --git a/recipes/busybox/busybox_1.13.2.bb b/recipes/busybox/busybox_1.13.2.bb
index 57815f68af..2b28c0b093 100644
--- a/recipes/busybox/busybox_1.13.2.bb
+++ b/recipes/busybox/busybox_1.13.2.bb
@@ -18,6 +18,7 @@ SRC_URI = "\
\
file://udhcpscript.patch \
file://udhcpc-fix-nfsroot.patch \
+ file://udhcpc-background.patch \
file://B921600.patch \
file://get_header_tar.patch \
file://busybox-appletlib-dependency.patch \