summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/autoconf/autoconf.inc7
1 files changed, 2 insertions, 5 deletions
diff --git a/recipes/autoconf/autoconf.inc b/recipes/autoconf/autoconf.inc
index e0ca21aae0..1815b5d80b 100644
--- a/recipes/autoconf/autoconf.inc
+++ b/recipes/autoconf/autoconf.inc
@@ -25,6 +25,8 @@ do_configure_prepend () {
export ac_cv_path_M4="${ac_cv_path_M4=${bindir}/m4}"
export ac_cv_prog_gnu_m4="${ac_cv_prog_gnu_m4=yes}"
fi
+
+ sed -i -e's,^SUBDIRS = .*,SUBDIRS = ${SUBDIRS},' ${S}/Makefile.am
}
do_configure_append() {
@@ -32,10 +34,5 @@ do_configure_append() {
sed -i -e "s:#! @PERL@ -w:#! /usr/bin/env perl:" ${S}/bin/*.in
}
-do_compile () {
- sed -i -e's,^SUBDIRS = .*,SUBDIRS = ${SUBDIRS},' Makefile
- oe_runmake
-}
-
PARALLEL_MAKE = ""
BBCLASSEXTEND = "native"