aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/angstrom/angstrom-gdm-autologin-hack.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/angstrom/angstrom-gdm-autologin-hack.bb b/recipes/angstrom/angstrom-gdm-autologin-hack.bb
new file mode 100644
index 0000000000..5c5d7e8172
--- /dev/null
+++ b/recipes/angstrom/angstrom-gdm-autologin-hack.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Append Autologin to GDM config (custom.conf)"
+
+PACKAGE_ARCH = "all"
+ALLOW_EMPTY_${PN} = "1"
+
+pkg_postinst_${PN}() {
+#!/bin/sh
+grep "TimedLogin" $D/etc/gdm/custom.conf
+if [ $? -eq 0 ]; then
+ echo "NOTE:: custom.conf already has 'TimedLogin' configured - not patching
+else
+ cat >> $D/etc/gdm/custom.conf <<EOF
+
+[daemon]
+TimedLoginEnable=true
+TimedLogin=root
+TimedLoginDelay=10
+
+EOF
+fi
+}
+
+RDEPENDS_${PN} = "gdm"